CC: base-files: sanitize and unify $PATH
authorJo-Philipp Wich <jow@openwrt.org>
Thu, 14 Jan 2016 14:27:20 +0000 (14:27 +0000)
committerJo-Philipp Wich <jow@openwrt.org>
Thu, 14 Jan 2016 14:27:20 +0000 (14:27 +0000)
Previously init and hotplug paths were different from console.

Signed-off-by: Steven Barth <steven@midlink.org>
Backport of r47080

SVN-Revision: 48237

package/base-files/Makefile
package/base-files/files/etc/preinit
package/base-files/files/etc/profile
package/base-files/files/sbin/hotplug-call

index 0bba313702f0f9a3b42122b4b6beed929296d355..5474265b1c8446629caecfa2d4775e4fead4eb75 100644 (file)
@@ -1,5 +1,5 @@
 #
-# Copyright (C) 2007-2014 OpenWrt.org
+# Copyright (C) 2007-2016 OpenWrt.org
 # Copyright (C) 2010 Vertical Communications
 #
 # This is free software, licensed under the GNU General Public License v2.
@@ -11,7 +11,7 @@ include $(INCLUDE_DIR)/kernel.mk
 include $(INCLUDE_DIR)/version.mk
 
 PKG_NAME:=base-files
-PKG_RELEASE:=157
+PKG_RELEASE:=157.1
 
 PKG_FILE_DEPENDS:=$(PLATFORM_DIR)/ $(GENERIC_PLATFORM_DIR)/base-files/
 PKG_BUILD_DEPENDS:=opkg/host usign/host
index 9cc8a9a8f63dd824f9c75b711d779aa8b2452259..31f861edf9f8552c7648d87e2627f3f6c9df784c 100755 (executable)
@@ -4,7 +4,7 @@
 
 [ -z "$PREINIT" ] && exec /sbin/init
 
-export PATH=/bin:/sbin:/usr/bin:/usr/sbin
+export PATH=/usr/sbin:/usr/bin:/sbin:/bin
 
 pi_ifname=
 pi_ip=192.168.1.1
@@ -20,7 +20,7 @@ fs_failsafe_wait_timeout=2
 
 pi_suppress_stderr="y"
 pi_init_suppress_stderr="y"
-pi_init_path="/bin:/sbin:/usr/bin:/usr/sbin"
+pi_init_path="/usr/sbin:/usr/bin:/sbin:/bin"
 pi_init_cmd="/sbin/init"
 
 . /lib/functions.sh
index 3dd58e14f28f22e3119733e9069861587baaaee1..170f48783375804d15faa72d9a45e228a153e69f 100644 (file)
@@ -2,7 +2,7 @@
 [ -f /etc/banner ] && cat /etc/banner
 [ -e /tmp/.failsafe ] && cat /etc/banner.failsafe
 
-export PATH=/usr/bin:/usr/sbin:/bin:/sbin
+export PATH=/usr/sbin:/usr/bin:/sbin:/bin
 export HOME=$(grep -e "^${USER:-root}:" /etc/passwd | cut -d ":" -f 6)
 export HOME=${HOME:-/root}
 export PS1='\u@\h:\w\$ '
index 260be0b7a4e9e834eda140142361e726d9eb4a30..743871a3ff4b729d7e0f7903d33604dc9850fb40 100755 (executable)
@@ -5,7 +5,7 @@ export HOTPLUG_TYPE="$1"
 
 . /lib/functions.sh
 
-PATH=/bin:/sbin:/usr/bin:/usr/sbin
+PATH=/usr/sbin:/usr/bin:/sbin:/bin
 LOGNAME=root
 USER=root
 export PATH LOGNAME USER