django-statici18n: update packaging format + add python3 variant
authorAlexandru Ardelean <ardeleanalex@gmail.com>
Wed, 3 Jul 2019 09:01:56 +0000 (12:01 +0300)
committerAlexandru Ardelean <ardeleanalex@gmail.com>
Thu, 11 Jul 2019 12:16:36 +0000 (15:16 +0300)
Signed-off-by: Alexandru Ardelean <ardeleanalex@gmail.com>
lang/python/django-statici18n/Makefile
net/seafile-seahub/Makefile

index b4a3898dcbfd9cac570c7e22cbd5a68317771543..97a880596178dbcbc501572f7f368e6a06765313 100644 (file)
@@ -9,39 +9,62 @@ include $(TOPDIR)/rules.mk
 
 PKG_NAME:=django-statici18n
 PKG_VERSION:=1.8.2
-PKG_RELEASE:=3
-PKG_LICENSE:=BSD-3-Clause
+PKG_RELEASE:=4
 
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
 PKG_SOURCE_URL:=https://files.pythonhosted.org/packages/source/d/django-statici18n
 PKG_HASH:=ba9eeb3c4517027922645999359f8335fbb9fea04c457123cfbd6b4a36cbeda4
+
 PKG_MAINTAINER:=Alexandru Ardelean <ardeleanalex@gmail.com>
+PKG_LICENSE:=BSD-3-Clause
+PKG_LICENSE_FILES:=LICENSE
+
+PKG_BUILD_DIR:=$(BUILD_DIR)/$(BUILD_VARIANT)-$(PKG_NAME)-$(PKG_VERSION)
 
 include $(INCLUDE_DIR)/package.mk
 include ../python-package.mk
+include ../python3-package.mk
 
-define Package/django-statici18n
+PKG_UNPACK:=$(HOST_TAR) -C $(PKG_BUILD_DIR) --strip-components=1 -xzf $(DL_DIR)/$(PKG_SOURCE)
+
+define Package/$(PKG_NAME)/Default
   SUBMENU:=Python
   SECTION:=lang
   CATEGORY:=Languages
-  TITLE:=A Django app that provides helper for generating JavaScript catalog to static files.
-  URL:=https://django-statici18n.readthedocs.org/
-  DEPENDS:=+python +python-django
+  TITLE:=Helper for generating JavaScript catalog to static files
+  URL:=https://$(PKG_NAME).readthedocs.io
+endef
+
+define Package/python-$(PKG_NAME)
+$(call Package/$(PKG_NAME)/Default)
+  DEPENDS:= \
+       +PACKAGE_python-$(PKG_NAME):python \
+       +PACKAGE_python-$(PKG_NAME):python-django
+  VARIANT:=python
 endef
 
-define Package/django-statici18n/description
+define Package/python-$(PKG_NAME)/description
   A Django app that provides helper for generating JavaScript catalog to static files.
 endef
 
-define Build/Compile
-       $(call Build/Compile/PyMod,,install --prefix=/usr --root=$(PKG_INSTALL_DIR))
+define Package/python3-$(PKG_NAME)
+$(call Package/$(PKG_NAME)/Default)
+  DEPENDS:= \
+       +PACKAGE_python3-$(PKG_NAME):python3 \
+       +PACKAGE_python3-$(PKG_NAME):python3-django
+  VARIANT:=python3
 endef
 
-define Package/django-statici18n/install
-       $(INSTALL_DIR) $(1)$(PYTHON_PKG_DIR)
-       $(CP) \
-           $(PKG_INSTALL_DIR)$(PYTHON_PKG_DIR)/* \
-           $(1)$(PYTHON_PKG_DIR)
+define Package/python3-$(PKG_NAME)/description
+$(call define Package/python-$(PKG_NAME)/description)
+.
+(Variant for Python3)
 endef
 
-$(eval $(call BuildPackage,django-statici18n))
+$(eval $(call PyPackage,python-$(PKG_NAME)))
+$(eval $(call BuildPackage,python-$(PKG_NAME)))
+$(eval $(call BuildPackage,python-$(PKG_NAME)-src))
+
+$(eval $(call Py3Package,python3-$(PKG_NAME)))
+$(eval $(call BuildPackage,python3-$(PKG_NAME)))
+$(eval $(call BuildPackage,python3-$(PKG_NAME)-src))
index 5c7eb89487b595196cf0fbd2dfaff89fda4d8884..41d36e16419de2daf7642a6f71507a2de3f83781 100644 (file)
@@ -30,7 +30,7 @@ SEAFILE_PYTHON_DEPENDS:= \
        simplejson chardet dateutil mysql pytz qrcode requests requests-oauthlib \
        django django-constance django-appconf django-compressor django-formtools \
        django-jsonfield django-picklefield django-postoffice django-restframework \
-       pillow django-simple-captcha
+       pillow django-simple-captcha django-statici18n
 
 define Package/seafile-seahub
   SECTION:=net
@@ -38,7 +38,7 @@ define Package/seafile-seahub
   TITLE:=Seafile server - seahub component
   URL:=https://seafile.com/
   DEPENDS:=+python \
-       +django-statici18n +django-webpack-loader \
+       +django-webpack-loader \
        +python-flup +gunicorn +openpyxl \
        $(foreach dep,$(SEAFILE_PYTHON_DEPENDS),+python-$(dep))
 endef