x86/build/vdso: Remove unused $(vobjs-nox32) in Makefile
authorMasahiro Yamada <yamada.masahiro@socionext.com>
Tue, 15 May 2018 02:52:22 +0000 (11:52 +0900)
committerIngo Molnar <mingo@kernel.org>
Tue, 15 May 2018 05:32:42 +0000 (07:32 +0200)
Since commit bfad381c0d1e ("x86/vdso: Improve the fake section
headers"), $(vobjs-nox32) is empty.  Therefore, $(vobjs64-for-x32)
is the same as $(vobjs-y).

Signed-off-by: Masahiro Yamada <yamada.masahiro@socionext.com>
Cc: Andy Lutomirski <luto@amacapital.net>
Cc: Linus Torvalds <torvalds@linux-foundation.org>
Cc: Peter Zijlstra <peterz@infradead.org>
Cc: Thomas Gleixner <tglx@linutronix.de>
Link: http://lkml.kernel.org/r/1526352744-28229-2-git-send-email-yamada.masahiro@socionext.com
Signed-off-by: Ingo Molnar <mingo@kernel.org>
arch/x86/entry/vdso/Makefile

index d998a487c9b1247a1bdc29d82827383bbbe8405b..298850683ee2d56e7776dbeb219d04cd930da108 100644 (file)
@@ -100,11 +100,8 @@ VDSO_LDFLAGS_vdsox32.lds = -Wl,-m,elf32_x86_64 \
                           -Wl,-z,max-page-size=4096 \
                           -Wl,-z,common-page-size=4096
 
-# 64-bit objects to re-brand as x32
-vobjs64-for-x32 := $(filter-out $(vobjs-nox32),$(vobjs-y))
-
 # x32-rebranded versions
-vobjx32s-y := $(vobjs64-for-x32:.o=-x32.o)
+vobjx32s-y := $(vobjs-y:.o=-x32.o)
 
 # same thing, but in the output directory
 vobjx32s := $(foreach F,$(vobjx32s-y),$(obj)/$F)