add pciutils package (thanks to Markus Wigge, partially closes: #533).
authorNicolas Thill <nico@openwrt.org>
Wed, 17 May 2006 01:03:25 +0000 (01:03 +0000)
committerNicolas Thill <nico@openwrt.org>
Wed, 17 May 2006 01:03:25 +0000 (01:03 +0000)
SVN-Revision: 3790

openwrt/package/Config.in
openwrt/package/Makefile
openwrt/package/pciutils/Config.in [new file with mode: 0644]
openwrt/package/pciutils/Makefile [new file with mode: 0644]
openwrt/package/pciutils/ipkg/pciutils.control [new file with mode: 0644]

index 231a22e7cee305088a5a488c87a595100f6c6f43..cf999987cd2b19fc076315cffb394f11db66f25a 100644 (file)
@@ -132,6 +132,7 @@ source "package/setserial/Config.in"
 comment "Utilities ---"
 source "package/gcom/Config.in"
 source "package/madwifi-tools/Config.in"
+source "package/pciutils/Config.in"
 source "package/pcmcia-cs/Config.in"  # pcmcia-utils
 source "package/strace/Config.in"
 source "package/usbutils/Config.in"  # lsusb
index c320f8e080c98f740d635c8c90a9e5df477abdd5..33e22717dda6ba2a52330f70e32865cad7ef7412 100644 (file)
@@ -79,6 +79,7 @@ package-$(BR2_PACKAGE_OPENSSL) += openssl
 package-$(BR2_PACKAGE_OPENSWAN) += openswan
 package-$(BR2_PACKAGE_OPENVPN) += openvpn
 package-$(BR2_PACKAGE_OSIRIS) += osiris
+package-$(BR2_PACKAGE_PCIUTILS) += pciutils
 package-$(BR2_COMPILE_PCMCIA_CS) += pcmcia-cs
 package-$(BR2_PACKAGE_PCRE) += pcre
 package-$(BR2_PACKAGE_PICOCOM) += picocom
diff --git a/openwrt/package/pciutils/Config.in b/openwrt/package/pciutils/Config.in
new file mode 100644 (file)
index 0000000..1b35408
--- /dev/null
@@ -0,0 +1,7 @@
+config BR2_PACKAGE_PCIUTILS
+       prompt "pciutils - Linux PCI Utilities"
+       tristate
+       default m
+       help
+         This package contains various utilities for inspecting and setting of
+         devices connected to the PCI bus.
diff --git a/openwrt/package/pciutils/Makefile b/openwrt/package/pciutils/Makefile
new file mode 100644 (file)
index 0000000..ab183e5
--- /dev/null
@@ -0,0 +1,37 @@
+# $Id$
+
+include $(TOPDIR)/rules.mk
+
+PKG_NAME:=pciutils
+PKG_VERSION:=2.2.1
+PKG_RELEASE:=1
+PKG_MD5SUM:=c18e2a5f04e9abae5a42439de294f086
+
+PKG_SOURCE_URL:=http://www.kernel.org/pub/software/utils/pciutils/ \
+       ftp://atrey.karlin.mff.cuni.cz/pub/linux/pci
+PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
+PKG_CAT:=zcat
+
+PKG_BUILD_DIR:=$(BUILD_DIR)/$(PKG_NAME)-$(PKG_VERSION)
+PKG_INSTALL_DIR:=$(PKG_BUILD_DIR)/ipkg-install
+
+include $(TOPDIR)/package/rules.mk
+
+$(eval $(call PKG_template,PCIUTILS,pciutils,$(PKG_VERSION)-$(PKG_RELEASE),$(ARCH)))
+
+$(PKG_BUILD_DIR)/.configured:
+       touch $@
+
+$(PKG_BUILD_DIR)/.built:
+       $(MAKE) -C $(PKG_BUILD_DIR) \
+               CC=$(TARGET_CC) CFLAGS="$(TARGET_CFLAGS)" IDSDIR="/usr/share" HOST=$(GNU_TARGET_NAME)
+       touch $@
+
+$(IPKG_PCIUTILS):
+       install -d -m0755 $(IDIR_PCIUTILS)/usr/sbin
+       install -m0755 $(PKG_BUILD_DIR)/lspci $(IDIR_PCIUTILS)/usr/sbin/
+       install -m0755 $(PKG_BUILD_DIR)/setpci $(IDIR_PCIUTILS)/usr/sbin/
+       install -d -m0755 $(IDIR_PCIUTILS)/usr/share
+       install -m0644 $(PKG_BUILD_DIR)/pci.ids $(IDIR_PCIUTILS)/usr/share/
+       $(RSTRIP) $(IDIR_PCIUTILS)/
+       $(IPKG_BUILD) $(IDIR_PCIUTILS) $(PACKAGE_DIR)
diff --git a/openwrt/package/pciutils/ipkg/pciutils.control b/openwrt/package/pciutils/ipkg/pciutils.control
new file mode 100644 (file)
index 0000000..b3f0c4e
--- /dev/null
@@ -0,0 +1,4 @@
+Package: pciutils
+Priority: optional
+Section: sys
+Description: Linux PCI Utilities