libdmapsharing: Add build dependency
authorRosen Penev <rosenp@gmail.com>
Mon, 14 Oct 2019 17:01:14 +0000 (10:01 -0700)
committerRosen Penev <rosenp@gmail.com>
Mon, 14 Oct 2019 17:06:01 +0000 (10:06 -0700)
glib2 no longer depends on its host build. Added here.

Fixed license information.

Added PKG_BUILD_PARALLEL:=1 for faster compilation.

Removed gstreamer1-libs dependency as gst1-plugins-base includes it.

Other cleanups for consistency between packages.

Signed-off-by: Rosen Penev <rosenp@gmail.com>
libs/libdmapsharing/Makefile

index 43a3c76cfe758359bca311c8015e27033b27d2af..d0ddad5db409c0cf66dc1fc6b0d34abfc4e23e9f 100644 (file)
@@ -11,30 +11,28 @@ include $(TOPDIR)/rules.mk
 
 PKG_NAME:=libdmapsharing
 PKG_VERSION:=3.9.7
-PKG_RELEASE:=1
-
-PKG_MAINTAINER:=W. Michael Petullo <mike@flyn.org>
-
-PKG_LICENSE:=LGPLv2.1
-PKG_LICENSE_FILES:=COPYING
+PKG_RELEASE:=2
 
 PKG_SOURCE:=libdmapsharing-$(PKG_VERSION).tar.gz
 PKG_SOURCE_URL:=https://www.flyn.org/projects/libdmapsharing/
 PKG_HASH:=745f4dc0b00db3e40721d041c883d813489814eaad3ca0f9ffb091e7e1acfa88
 
+PKG_MAINTAINER:=W. Michael Petullo <mike@flyn.org>
+PKG_LICENSE:=LGPL-2.1-or-later
+PKG_LICENSE_FILES:=COPYING
+
 PKG_FIXUP:=autoreconf
 PKG_INSTALL:=1
+PKG_BUILD_PARALLEL:=1
+PKG_BUILD_DEPENDS:=glib2/host
 
 include $(INCLUDE_DIR)/package.mk
 include $(INCLUDE_DIR)/nls.mk
 
-TARGET_LDFLAGS+= \
-       -Wl,-rpath-link=$(STAGING_DIR)/usr/lib
-
 define Package/libdmapsharing
   SECTION:=libs
   CATEGORY:=Libraries
-  DEPENDS:=+libsoup +mdnsresponder +gstreamer1-libs +gstreamer1-plugins-base +gst1-mod-app
+  DEPENDS:=+libsoup +mdnsresponder +gstreamer1-plugins-base +gst1-mod-app
   TITLE:=libdmapsharing
   URL:=https://www.flyn.org/projects/libdmapsharing/
 endef