python-hatch-requirements-txt: Add new host-only package
authorJeffery To <jeffery.to@gmail.com>
Mon, 29 May 2023 18:19:56 +0000 (02:19 +0800)
committerJeffery To <jeffery.to@gmail.com>
Sat, 3 Jun 2023 17:00:22 +0000 (01:00 +0800)
From the README:

Hatchling plugin to read project dependencies from requirements.txt

Signed-off-by: Jeffery To <jeffery.to@gmail.com>
(cherry picked from commit 9071deb1c78ec251d2a25f178f37a1ab633b8de2)

lang/python/python-hatch-requirements-txt/Makefile [new file with mode: 0644]

diff --git a/lang/python/python-hatch-requirements-txt/Makefile b/lang/python/python-hatch-requirements-txt/Makefile
new file mode 100644 (file)
index 0000000..ae6cd13
--- /dev/null
@@ -0,0 +1,53 @@
+#
+# Copyright (C) 2023 Jeffery To
+#
+# This is free software, licensed under the GNU General Public License v2.
+# See /LICENSE for more information.
+#
+
+include $(TOPDIR)/rules.mk
+
+PKG_NAME:=python-hatch-requirements-txt
+PKG_VERSION:=0.4.0
+PKG_RELEASE:=1
+
+PYPI_NAME:=hatch-requirements-txt
+PYPI_SOURCE_NAME:=hatch_requirements_txt
+PKG_HASH:=800509946e85d9e56d73242fab223ec36db50372e870a04e2dd1fd9bad98455d
+
+PKG_LICENSE:=MIT
+PKG_LICENSE_FILES:=LICENSE
+PKG_MAINTAINER:=Jeffery To <jeffery.to@gmail.com>
+
+PKG_HOST_ONLY:=1
+HOST_BUILD_DEPENDS:= \
+       python3/host \
+       python-build/host \
+       python-installer/host \
+       python-hatchling/host \
+       python-packaging/host
+
+include ../pypi.mk
+include $(INCLUDE_DIR)/package.mk
+include $(INCLUDE_DIR)/host-build.mk
+include ../python3-package.mk
+include ../python3-host-build.mk
+
+define Package/python3-hatch-requirements-txt
+  SECTION:=lang
+  CATEGORY:=Languages
+  SUBMENU:=Python
+  TITLE:=Read project dependencies from requirements.txt
+  URL:=https://github.com/repo-helper/hatch-requirements-txt
+  DEPENDS:=+python3-light +python3-hatchling +python3-packaging
+  BUILDONLY:=1
+endef
+
+define Package/python3-hatch-requirements-txt/description
+Hatchling plugin to read project dependencies from requirements.txt
+endef
+
+$(eval $(call Py3Package,python3-hatch-requirements-txt))
+$(eval $(call BuildPackage,python3-hatch-requirements-txt))
+$(eval $(call BuildPackage,python3-hatch-requirements-txt-src))
+$(eval $(call HostBuild))