setools: new package
authorW. Michael Petullo <mike@flyn.org>
Fri, 7 Aug 2020 18:52:41 +0000 (13:52 -0500)
committerPaul Spooren <mail@aparcar.org>
Sat, 12 Sep 2020 00:50:24 +0000 (14:50 -1000)
Signed-off-by: W. Michael Petullo <mike@flyn.org>
utils/setools/Makefile [new file with mode: 0644]
utils/setools/patches/010-fewer-warnings.patch [new file with mode: 0644]

diff --git a/utils/setools/Makefile b/utils/setools/Makefile
new file mode 100644 (file)
index 0000000..ba38e4f
--- /dev/null
@@ -0,0 +1,41 @@
+#
+# This is free software, licensed under the GNU General Public License v2.
+# See /LICENSE for more information.
+#
+
+include $(TOPDIR)/rules.mk
+
+PKG_NAME:=setools
+PKG_VERSION:=4.3.0
+PKG_RELEASE:=1
+
+PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.bz2
+PKG_SOURCE_URL:=https://github.com/SELinuxProject/setools/releases/download/4.3.0
+PKG_HASH:=315df3ae0eb29b399123c5e3330480c5d1c0da038671c9fd62a439c49a6f9105
+PKG_BUILD_DIR:=$(BUILD_DIR)/setools
+
+HOST_PYTHON3_PACKAGE_BUILD_DEPENDS:=Cython # Cython>=0.27
+
+PKG_MAINTAINER:=W. Michael Petullo <mike@flyn.org>
+PKG_LICENSE:=GPL-2.0-or-later LGPL-2.1-or-later
+PKG_LICENSE_FILES:=COPYING COPYING.GPL COPYING.LGPL
+PKG_CPE_ID:=cpe:/a:selinuxproject:setools
+
+include $(INCLUDE_DIR)/package.mk
+include ../../lang/python/python3-package.mk
+
+define Package/setools
+  SECTION:=utils
+  CATEGORY:=Utilities
+  DEPENDS:=+python3 +python3-pkg-resources +python3-networkx +libselinux +libsepol
+  TITLE:=Policy analysis tools for SELinux
+  URL:=http://selinuxproject.org/page/Main_Page
+endef
+
+define Package/setools/description
+  SETools is a collection of tools and libraries designed to facilitate
+  SELinux policy analysis.
+endef
+
+$(eval $(call Py3Package,setools))
+$(eval $(call BuildPackage,setools))
diff --git a/utils/setools/patches/010-fewer-warnings.patch b/utils/setools/patches/010-fewer-warnings.patch
new file mode 100644 (file)
index 0000000..d81a9c6
--- /dev/null
@@ -0,0 +1,11 @@
+diff -u --recursive setools-vanilla/setup.py setools/setup.py
+--- setools-vanilla/setup.py   2020-04-01 09:57:49.000000000 -0500
++++ setools/setup.py   2020-08-12 21:44:41.265149504 -0500
+@@ -109,7 +109,6 @@
+                          extra_compile_args=['-Werror', '-Wextra',
+                                              '-Waggregate-return',
+                                              '-Wfloat-equal',
+-                                             '-Wformat', '-Wformat=2',
+                                              '-Winit-self',
+                                              '-Wmissing-format-attribute',
+                                              '-Wmissing-include-dirs',