samples/bpf: fix include path in Makefile
authorPrashant Bhole <prashantbhole.linux@gmail.com>
Fri, 14 Jun 2019 06:43:18 +0000 (15:43 +0900)
committerDaniel Borkmann <daniel@iogearbox.net>
Fri, 14 Jun 2019 23:14:06 +0000 (01:14 +0200)
Recent commit included libbpf.h in selftests/bpf/bpf_util.h.
Since some samples use bpf_util.h and samples/bpf/Makefile doesn't
have libbpf.h path included, build was failing. Let's add the path
in samples/bpf/Makefile.

Signed-off-by: Prashant Bhole <prashantbhole.linux@gmail.com>
Signed-off-by: Daniel Borkmann <daniel@iogearbox.net>
samples/bpf/Makefile

index 9eb5d733f575d00f6bf0b7c1dbc0f7a311a084c1..34bc7e17c994aaccfc7adfab405783e5fd4228a9 100644 (file)
@@ -170,7 +170,7 @@ always += ibumad_kern.o
 always += hbm_out_kern.o
 
 KBUILD_HOSTCFLAGS += -I$(objtree)/usr/include
-KBUILD_HOSTCFLAGS += -I$(srctree)/tools/lib/
+KBUILD_HOSTCFLAGS += -I$(srctree)/tools/lib/bpf/
 KBUILD_HOSTCFLAGS += -I$(srctree)/tools/testing/selftests/bpf/
 KBUILD_HOSTCFLAGS += -I$(srctree)/tools/lib/ -I$(srctree)/tools/include
 KBUILD_HOSTCFLAGS += -I$(srctree)/tools/perf