ttyd: fix debug config option
authorFlorian Eckert <fe@dev.tdt.de>
Mon, 3 Aug 2020 13:41:04 +0000 (15:41 +0200)
committerFlorian Eckert <fe@dev.tdt.de>
Mon, 3 Aug 2020 13:47:32 +0000 (15:47 +0200)
Append missing debug option value.
If this is not append and the debug option is selected, then we get the
following error output on ttyd start.

> ttyd: missing start command

To fix this add missing debug option value.

Signed-off-by: Florian Eckert <fe@dev.tdt.de>
utils/ttyd/Makefile
utils/ttyd/files/ttyd.init

index 2e195f8216519ff23c1475bf30ffc26b492afa32..3e2c7a9a04976f7403948eed3ecf40f2dae8ddad 100644 (file)
@@ -9,7 +9,7 @@ include $(TOPDIR)/rules.mk
 
 PKG_NAME:=ttyd
 PKG_VERSION:=1.6.1
-PKG_RELEASE:=1
+PKG_RELEASE:=2
 
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
 PKG_SOURCE_URL:=https://codeload.github.com/tsl0922/ttyd/tar.gz/$(PKG_VERSION)?
index 7206ff74267ebdd3876bd0936e0946a7492c8e6e..0a3d440a98656413aacc2efb85c711a4b9a20967 100644 (file)
@@ -79,7 +79,7 @@ ttyd_instance()
                ${ssl_cert:+-C $ssl_cert} \
                ${ssl_key:+-K $ssl_key} \
                ${ssl_ca:+-A $ssl_ca} \
-               ${debug:+-d}
+               ${debug:+-d $debug}
        config_list_foreach "$1" client_option "procd_append_param command -t"
        procd_append_param command $command
        procd_set_param stdout 1