i2c-tools: Pass LDFLAGS
authorLars-Peter Clausen <lars@metafoo.de>
Sun, 7 Jul 2013 20:22:35 +0000 (20:22 +0000)
committerLars-Peter Clausen <lars@metafoo.de>
Sun, 7 Jul 2013 20:22:35 +0000 (20:22 +0000)
Pass LDFLAGS when building the i2c-tools. This fixes the build under certain
exotic configurations.

SVN-Revision: 37188

utils/i2c-tools/Makefile

index 16feedb2794988b5acbf0c417efbc918472f6b9b..9ef752baaad70bd93b0700c9f1fc39f328f3aba0 100644 (file)
@@ -68,7 +68,8 @@ define Build/Compile
        $(MAKE) -C $(PKG_BUILD_DIR) \
                LINUX="$(LINUX_DIR)" \
                CC="$(TARGET_CC)" \
-               STAGING_DIR="$(STAGING_DIR)"
+               STAGING_DIR="$(STAGING_DIR)" \
+               LDFLAGS="$(TARGET_LDFLAGS)"
        $(Build/Compile/python-smbus)
 endef