mwan3: allow interfaces with no tracking IPs
authorAaron Goodman <aaronjg@stanford.edu>
Wed, 28 Apr 2021 23:42:38 +0000 (19:42 -0400)
committerAaron Goodman <aaronjg@stanford.edu>
Sun, 2 May 2021 23:13:44 +0000 (19:13 -0400)
In the procd refactor, support for interfaces with no tracking IPs was
inadvertentiy removed. This commit restores the previous behavior

Signed-off-by: Aaron Goodman <aaronjg@stanford.edu>
net/mwan3/Makefile
net/mwan3/files/etc/init.d/mwan3

index 6909505f7f8dabec4c10f2af37e7940f47359cca..e4c3aea85fc2e3ca84a18f2d0e1285137eb898e3 100644 (file)
@@ -8,7 +8,7 @@
 include $(TOPDIR)/rules.mk
 
 PKG_NAME:=mwan3
-PKG_VERSION:=2.10.8
+PKG_VERSION:=2.10.9
 PKG_RELEASE:=1
 PKG_MAINTAINER:=Florian Eckert <fe@dev.tdt.de>, \
                Aaron Goodman <aaronjg@alumni.stanford.edu>
index 2d5b53d2338c5ccaa3653e57364aa2f99ad3eff7..560621516657df0fd3ad51e55bbebbd09c22efa9 100755 (executable)
@@ -17,6 +17,7 @@ start_tracker() {
        interface=$1
        config_get_bool enabled $interface 'enabled' '0'
        [ $enabled -eq 0 ] && return
+       [ -z "$(config_get $interface track_ip)" ] && return
 
        procd_open_instance "track_${1}"
        procd_set_param command /usr/sbin/mwan3track $interface