clamsmtp: Really fix compilation
authorRosen Penev <rosenp@gmail.com>
Mon, 12 Nov 2018 20:32:14 +0000 (12:32 -0800)
committerRosen Penev <rosenp@gmail.com>
Mon, 12 Nov 2018 20:34:54 +0000 (12:34 -0800)
It seems Linux headers are broken/incompatible with musl for some reason.

Signed-off-by: Rosen Penev <rosenp@gmail.com>
mail/clamsmtp/Makefile
mail/clamsmtp/patches/010-fix-build.patch

index aa3e31e4f2daa45d4c4e94d3f5687f27b8042538..3eb6d88beb859785823a8eac9042878e98f9fabd 100644 (file)
@@ -9,7 +9,7 @@ include $(TOPDIR)/rules.mk
 
 PKG_NAME:=clamsmtp
 PKG_VERSION:=1.10
-PKG_RELEASE:=2
+PKG_RELEASE:=3
 
 PKG_SOURCE_URL:=http://thewalter.net/stef/software/clamsmtp/
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
index a3d88dceeca0675a612befac755c86ae8e131d48..a285a77398d1880c4c58c9406935014f2e2b0c74 100644 (file)
@@ -1,12 +1,19 @@
-diff --git a/common/sock_any.h b/common/sock_any.h
-index 77c3841..1e30974 100644
---- a/common/sock_any.h
-+++ b/common/sock_any.h
-@@ -39,7 +39,6 @@
- #ifndef __SOCK_ANY_H__
- #define __SOCK_ANY_H__
--#include <sys/socket.h>
- #include <sys/un.h>
- #include <netinet/in.h>
+--- a/configure.in
++++ b/configure.in
+@@ -78,16 +78,6 @@ AC_CHECK_HEADERS([limits.h err.h paths.h],,)
+ AC_CHECK_HEADERS([unistd.h stdio.h stddef.h fcntl.h stdlib.h assert.h errno.h stdarg.h string.h netdb.h], ,
+     [echo "ERROR: Required C header missing"; exit 1])
  
+-# Check for linux type transparent proxy support
+-AC_CHECK_HEADERS([linux/netfilter_ipv4.h],
+-   AC_DEFINE(LINUX_TRANSPARENT_PROXY, 1, [Whether the system supports a linux type transparent proxy]),
+-   , 
+-   [[
+-   #ifdef HAVE_LIMITS_H
+-   #include <limits.h>
+-   #endif
+-   ]] )
+-
+ # Checks for typedefs, structures, and compiler characteristics.
+ AC_C_CONST
+ AC_TYPE_SIZE_T