projects
/
openwrt
/
svn-archive
/
packages.git
/ commitdiff
commit
grep
author
committer
pickaxe
?
search:
re
summary
|
shortlog
|
log
|
commit
| commitdiff |
tree
raw
|
patch
| inline |
side by side
(parent:
b91dbef
)
iperf: fix g++-uc override, add -lpthread explicitly for iperf-mt
author
Felix Fietkau
<nbd@openwrt.org>
Wed, 26 Jan 2011 13:49:28 +0000
(13:49 +0000)
committer
Felix Fietkau
<nbd@openwrt.org>
Wed, 26 Jan 2011 13:49:28 +0000
(13:49 +0000)
SVN-Revision: 25114
net/iperf/Makefile
patch
|
blob
|
history
diff --git
a/net/iperf/Makefile
b/net/iperf/Makefile
index a173b7d9360bb3ca8c1d6b6568f3f5853602b353..473c0625d36c55819649c3300dbd61a1bada1b3e 100644
(file)
--- a/
net/iperf/Makefile
+++ b/
net/iperf/Makefile
@@
-67,9
+67,13
@@
else
CONFIGURE_VARS += ac_cv_func_pthread_cancel=no
endif
-CONFIGURE_VARS += \
- CXX="g++-uc" \
- CXXFLAGS="$$$$CXXFLAGS -fno-rtti" \
+TARGET_CXX=g++-uc
+
+CONFIGURE_VARS += CXXFLAGS="$$$$CXXFLAGS -fno-rtti"
+
+ifeq ($(BUILD_VARIANT),mt)
+ CONFIGURE_VARS += LIBS="-lpthread"
+endif
define Package/iperf/install
$(INSTALL_DIR) $(1)/usr/bin