python-more-itertools: add new package
authorJan Pavlinec <jan.pavlinec@nic.cz>
Thu, 31 Oct 2019 12:26:48 +0000 (13:26 +0100)
committerRosen Penev <rosenp@gmail.com>
Fri, 6 Dec 2019 23:41:53 +0000 (15:41 -0800)
Signed-off-by: Jan Pavlinec <jan.pavlinec@nic.cz>
(cherry-picked from 4bade3b2f7448150d6ca210a1bd27b352efe7b42)

lang/python/python-more-itertools/Makefile [new file with mode: 0644]

diff --git a/lang/python/python-more-itertools/Makefile b/lang/python/python-more-itertools/Makefile
new file mode 100644 (file)
index 0000000..5feb3df
--- /dev/null
@@ -0,0 +1,42 @@
+#
+# Copyright (C) 2019 CZ.NIC, z. s. p. o. (https://www.nic.cz/)
+#
+# This is free software, licensed under the GNU General Public License v2.
+# See /LICENSE for more information.
+#
+
+include $(TOPDIR)/rules.mk
+
+PKG_NAME:=python-more-itertools
+PKG_VERSION:=7.2.0
+PKG_RELEASE:=1
+
+PYPI_NAME:=more-itertools
+PKG_HASH:=409cd48d4db7052af495b09dec721011634af3753ae1ef92d2b32f73a745f832
+
+PKG_MAINTAINER:=Jan Pavlinec <jan.pavlinec@nic.cz>
+PKG_LICENSE:=MIT
+PKG_LICENSE_FILES:=LICENSE
+
+include ../pypi.mk
+include $(INCLUDE_DIR)/package.mk
+include ../python3-package.mk
+
+define Package/python3-more-itertools
+  SUBMENU:=Python
+  SECTION:=lang
+  CATEGORY:=Languages
+  TITLE:=More routines for operating on iterables, beyond itertools
+  URL:=https://github.com/erikrose/more-itertools
+  DEPENDS:=+python3-light
+  VARIANT:=python3
+endef
+
+define Package/python3-more-itertools/description
+  more-itertools library collects additional building blocks,
+  recipes, and routines for working with Python iterables.
+endef
+
+$(eval $(call Py3Package,python3-more-itertools))
+$(eval $(call BuildPackage,python3-more-itertools))
+$(eval $(call BuildPackage,python3-more-itertools-src))