zerotier: fix segfault on ARM platforms
authorMoritz Warning <moritzwarning@web.de>
Wed, 13 Apr 2022 19:19:38 +0000 (21:19 +0200)
committerMoritz Warning <moritzwarning@web.de>
Fri, 22 Apr 2022 05:28:32 +0000 (07:28 +0200)
Signed-off-by: Moritz Warning <moritzwarning@web.de>
(cherry picked from commit b45d39c1423444672abf8ea4ce3b53f75a1b2741)

net/zerotier/Makefile
net/zerotier/patches/0001-fix-makefile.patch

index f7ffd766eb8a7b9a05f3a833fa775b5e158d5cdd..a5cfa5fae3835eac5aca884e10a89e0d1c149ed2 100644 (file)
@@ -56,7 +56,7 @@ endif
 endef
 
 # Make binary smaller
-TARGET_CFLAGS += -ffunction-sections -fdata-sections -fPIE
+TARGET_CFLAGS += -ffunction-sections -fdata-sections
 TARGET_LDFLAGS += -Wl,--gc-sections,--as-needed
 
 define Package/zerotier/conffiles
index c5fc53feaf269b87dea40ad2602408eef4be1b82..2bc1aae8f262b2e21941ed1c948d1504ee86feb6 100644 (file)
@@ -29,6 +29,21 @@ Subject: [PATCH 1/3] fix makefile
        ONE_OBJS+=ext/libnatpmp/natpmp.o ext/libnatpmp/getgateway.o
  else
        LDLIBS+=-lnatpmp
+@@ -66,11 +66,11 @@ ifeq ($(ZT_DEBUG),1)
+       # C25519 in particular is almost UNUSABLE in -O0 even on a 3ghz box!
+ node/Salsa20.o node/SHA512.o node/C25519.o node/Poly1305.o: CXXFLAGS=-Wall -O2 -g -pthread $(INCLUDES) $(DEFS)
+ else
+-      CFLAGS?=-O3 -fstack-protector -fPIE
++      CFLAGS?=-O3 -fstack-protector
+       override CFLAGS+=-Wall -Wno-deprecated -pthread $(INCLUDES) -DNDEBUG $(DEFS)
+-      CXXFLAGS?=-O3 -fstack-protector -fPIE
++      CXXFLAGS?=-O3 -fstack-protector
+       override CXXFLAGS+=-Wall -Wno-deprecated -std=c++11 -pthread $(INCLUDES) -DNDEBUG $(DEFS)
+-      LDFLAGS=-pie -Wl,-z,relro,-z,now
++      LDFLAGS+=-Wl,-z,relro,-z,now
+       RUSTFLAGS=--release
+ endif
 @@ -300,7 +300,7 @@ ifeq ($(ZT_CONTROLLER),1)
  endif