projects
/
feed
/
packages.git
/ commitdiff
commit
grep
author
committer
pickaxe
?
search:
re
summary
|
shortlog
|
log
|
commit
| commitdiff |
tree
raw
|
patch
| inline |
side by side
(parent:
abf2889
)
golang: enable verbose output
author
Michael Pratt
<mcpratt@pm.me>
Fri, 20 May 2022 09:09:40 +0000
(
05:09
-0400)
committer
Michael Pratt
<mcpratt@pm.me>
Fri, 27 May 2022 06:39:52 +0000
(
02:39
-0400)
allow the building script of Go to output verbose
when make is executed with "V=s..."
Signed-off-by: Michael Pratt <mcpratt@pm.me>
lang/golang/golang-compiler.mk
patch
|
blob
|
history
diff --git
a/lang/golang/golang-compiler.mk
b/lang/golang/golang-compiler.mk
index c6c83601719a275d9422e2f080a0867511a6fb81..8f9c9a380e78e0d3d61c5cda196d057d21ef95eb 100644
(file)
--- a/
lang/golang/golang-compiler.mk
+++ b/
lang/golang/golang-compiler.mk
@@
-27,7
+27,10
@@
define GoCompiler/Default/Make
cd "$(1)/src" ; \
$(if $(2),GOROOT_FINAL="$(2)/lib/go-$(3)") \
$(4) \
- $(BASH) make.bash --no-banner ; \
+ $(BASH) make.bash \
+ $(if $(findstring s,$(OPENWRT_VERBOSE)),-v) \
+ --no-banner \
+ ; \
)
endef