pps-tools: install timepps.h in location specified by RFC 2783
authorWolfgang Breyha <wbreyha@gmx.net>
Sat, 19 Oct 2019 18:04:06 +0000 (20:04 +0200)
committerJosef Schlehofer <pepe.schlehofer@gmail.com>
Fri, 8 Nov 2019 09:58:57 +0000 (10:58 +0100)
This is need by eg. gpsd to build with proper PPS support.
It was already submitted once in #2892 which ended in a stalemate.
Signed-off-by: Wolfgang Breyha <wbreyha@gmx.net>
utils/pps-tools/Makefile

index 695114760cb2e56d2ee6d698d2abef3b9bd77367..d5bfd897ad9142e1733e3c052164fffd4f5cb7e0 100644 (file)
@@ -33,8 +33,8 @@ endef
 TARGET_CFLAGS += -I$(STAGING_DIR)/usr/include
 
 define Build/InstallDev
-       $(INSTALL_DIR) $(1)/usr/include
-       $(CP) $(PKG_BUILD_DIR)/timepps.h $(1)/usr/include/
+       $(INSTALL_DIR) $(1)/usr/include/sys
+       $(CP) $(PKG_BUILD_DIR)/timepps.h $(1)/usr/include/sys/
 endef
 
 define Package/pps-tools/install