mariadb: security bump to 10.1.35
authorSebastian Kemper <sebastian_ml@gmx.net>
Sat, 11 Aug 2018 20:59:22 +0000 (22:59 +0200)
committerSebastian Kemper <sebastian_ml@gmx.net>
Sat, 11 Aug 2018 20:59:24 +0000 (22:59 +0200)
Bump minor version. Bugfix release. 100% backward compatible.

Includes fixes for:

CVE-2018-3064
CVE-2018-3063
CVE-2018-3058
CVE-2018-3066

Also includes CPPFLAGS fix from master (to get fortify-source headers
etc.).

Signed-off-by: Sebastian Kemper <sebastian_ml@gmx.net>
utils/mariadb/Makefile
utils/mariadb/patches/100-fix_hostname.patch

index 92cadf31b86e6da1c3f884676c9966782992c9fa..d9b7c4dec18ee35dd5469ee650cdfef94f3c40e2 100644 (file)
@@ -8,7 +8,7 @@
 include $(TOPDIR)/rules.mk
 
 PKG_NAME:=mariadb
-PKG_VERSION:=10.1.34
+PKG_VERSION:=10.1.35
 PKG_RELEASE:=1
 
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
@@ -18,7 +18,7 @@ PKG_SOURCE_URL := \
        https://ftp.yz.yamagata-u.ac.jp/pub/dbms/mariadb/$(PKG_NAME)-$(PKG_VERSION)/source \
        https://downloads.mariadb.org/interstitial/$(PKG_NAME)-$(PKG_VERSION)/source
 
-PKG_HASH:=c7e0719fd08790c096585bf867fe87e084b310f2f3679e059e3b10b9fd6d5548
+PKG_HASH:=9e91d985ed4f662126e3e5791fe91ec8a2f44ec811113c2b6fbc72fa14553c4d
 PKG_MAINTAINER:=Sebastian Kemper <sebastian_ml@gmx.net>
 PKG_LICENSE:=GPL-2.0
 PKG_LICENSE_FILES:=COPYING
@@ -176,6 +176,10 @@ include $(INCLUDE_DIR)/package.mk
 include $(INCLUDE_DIR)/host-build.mk
 include $(INCLUDE_DIR)/cmake.mk
 
+# Pass CPPFLAGS in the CFLAGS as otherwise the build system will
+# ignore them.
+TARGET_CFLAGS+=$(TARGET_CPPFLAGS)
+
 define Package/mariadb/install/bin
        $(INSTALL_BIN) $(PKG_INSTALL_DIR)/usr/bin/$(2) $(1)/usr/bin
 endef
index 05a0fc6db14a677e387e843e80ba95a3c86b137b..33159cbb3544c1a7e7e8b614c020a2ba4a3431f1 100644 (file)
@@ -1,6 +1,6 @@
 --- a/scripts/mysql_install_db.sh
 +++ b/scripts/mysql_install_db.sh
-@@ -379,7 +379,7 @@ fi
+@@ -384,7 +384,7 @@ fi
  
  
  # Try to determine the hostname