libevent: cleanup, fix cflags
authorFelix Fietkau <nbd@openwrt.org>
Tue, 31 Jul 2007 10:46:18 +0000 (10:46 +0000)
committerFelix Fietkau <nbd@openwrt.org>
Tue, 31 Jul 2007 10:46:18 +0000 (10:46 +0000)
SVN-Revision: 8271

libs/libevent/Makefile

index 9a9663970877b54818d32a5c5474985dcc1573c3..bb6aea51c11d02ac2fbf46dab9988c25d0cf7a74 100644 (file)
@@ -39,18 +39,14 @@ define Package/libevent
   URL:=http://www.monkey.org/~provos/libevent/
 endef
 
-define Build/Configure
-       $(call Build/Configure/Default, \
-               --enable-shared \
-               --enable-static \
-       )
-endef
+CONFIGURE_ARGS += \
+       --enable-shared \
+       --enable-static \
 
-define Build/Compile
-       $(MAKE) -C $(PKG_BUILD_DIR) \
-               DESTDIR="$(PKG_INSTALL_DIR)" \
-               all install
-endef
+MAKE_FLAGS += \
+       CFLAGS="$(TARGET_CFLAGS)" \
+       DESTDIR="$(PKG_INSTALL_DIR)" \
+       all install
 
 define Build/InstallDev
        mkdir -p $(STAGING_DIR)/usr/include