mktorrent: fix bad format for 64bit platforms
authorRosen Penev <rosenp@gmail.com>
Mon, 31 Jan 2022 07:19:58 +0000 (23:19 -0800)
committerRosen Penev <rosenp@gmail.com>
Tue, 15 Feb 2022 01:20:22 +0000 (17:20 -0800)
The Makefile tries and fails to run a binary that sets it properly. Just
hardcode it.

Signed-off-by: Rosen Penev <rosenp@gmail.com>
utils/mktorrent/Makefile
utils/mktorrent/patches/010-format.patch [new file with mode: 0644]

index 3bc241a617fbdf85b643bd7164c854d68ec090bb..4afbba4b75dd96322cbcc10bf10e2336d73b1499 100644 (file)
@@ -9,7 +9,7 @@ include $(TOPDIR)/rules.mk
 
 PKG_NAME:=mktorrent
 PKG_VERSION:=1.1
-PKG_RELEASE:=1
+PKG_RELEASE:=2
 
 PKG_SOURCE_PROTO:=git
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.xz
diff --git a/utils/mktorrent/patches/010-format.patch b/utils/mktorrent/patches/010-format.patch
new file mode 100644 (file)
index 0000000..e7f62b0
--- /dev/null
@@ -0,0 +1,20 @@
+--- a/GNUmakefile
++++ b/GNUmakefile
+@@ -61,6 +61,6 @@ OBJS = $(SRCS:.c=.o)
+ all: $(program)
+ %.o: %.c $(HEADERS) prefix
+-      $(CC) $(CFLAGS) $(DEFINES) -DPRIoff="\"$(OFFPRFX)d\"" -DVERSION="\"$(version)\"" -c $<
++      $(CC) $(CFLAGS) $(DEFINES) -DPRIoff="PRId64 \"d\"" -DVERSION="\"$(version)\"" -c $<
+ include rules.mk
+--- a/init.c
++++ b/init.c
+@@ -25,6 +25,7 @@ Foundation, Inc., 51 Franklin Street, Fi
+ #include <sys/stat.h>     /* the stat structure */
+ #include <unistd.h>       /* getopt(), getcwd(), sysconf() */
+ #include <string.h>       /* strcmp(), strlen(), strncpy() */
++#include <inttypes.h>
+ #ifdef USE_LONG_OPTIONS
+ #include <getopt.h>       /* getopt_long() */
+ #endif