projects
/
project
/
netifd.git
/ commitdiff
commit
grep
author
committer
pickaxe
?
search:
re
summary
|
shortlog
|
log
|
commit
| commitdiff |
tree
raw
|
patch
| inline |
side by side
(parent:
5c8785a
)
add a variable for overriding the libnl linker command
author
Felix Fietkau
<nbd@openwrt.org>
Sun, 9 Oct 2011 16:57:42 +0000
(18:57 +0200)
committer
Felix Fietkau
<nbd@openwrt.org>
Sun, 9 Oct 2011 16:57:42 +0000
(18:57 +0200)
CMakeLists.txt
patch
|
blob
|
history
diff --git
a/CMakeLists.txt
b/CMakeLists.txt
index 461c07c8638c505829d767e907d487f497fc75f8..a6e228a05ec8b41c73ee4985340428f6b5784d73 100644
(file)
--- a/
CMakeLists.txt
+++ b/
CMakeLists.txt
@@
-19,9
+19,13
@@
SET(SOURCES
SET(LIBS
ubox ubus uci json blobmsg_json)
+IF (NOT DEFINED LIBNL_LIBS)
+ SET(LIBNL_LIBS -lnl)
+ENDIF()
+
IF("${CMAKE_SYSTEM_NAME}" MATCHES "Linux" AND NOT DUMMY_MODE)
SET(SOURCES ${SOURCES} system-linux.c)
- SET(LIBS ${LIBS}
nl
)
+ SET(LIBS ${LIBS}
${LIBNL_LIBS}
)
ELSE()
ADD_DEFINITIONS(-DDUMMY_MODE=1)
SET(SOURCES ${SOURCES} system-dummy.c)