nginx: create empty directory for module.d include
authorChristian Marangi <ansuelsmth@gmail.com>
Mon, 12 Jun 2023 15:06:16 +0000 (17:06 +0200)
committerChristian Marangi <ansuelsmth@gmail.com>
Mon, 12 Jun 2023 15:11:10 +0000 (17:11 +0200)
Fix a bug on installation of nginx-mod-luci where module.d directory
is not found and luci.module creation fails.
Correctly create empty directory for module.d include for dynamic module
loading by placing file in this directory.

Signed-off-by: Christian Marangi <ansuelsmth@gmail.com>
(cherry picked from commit 9365622f27284e1541ef24a1f4a52d32a439e24b)

net/nginx/Makefile

index 613e49f49bfe2b90be0c5e277918caa29d0412ea..17dd463ae77a0c6dae8044aa3c5a34fd1b1d8f8a 100644 (file)
@@ -9,7 +9,7 @@ include $(TOPDIR)/rules.mk
 
 PKG_NAME:=nginx
 PKG_VERSION:=1.25.0
-PKG_RELEASE:=1
+PKG_RELEASE:=2
 
 PKG_SOURCE:=nginx-$(PKG_VERSION).tar.gz
 PKG_SOURCE_URL:=https://nginx.org/download/
@@ -427,6 +427,7 @@ endef
 define Package/nginx-ssl/install
        $(INSTALL_DIR) $(1)/usr/sbin
        $(INSTALL_BIN) $(PKG_INSTALL_DIR)/usr/sbin/nginx $(1)/usr/sbin/
+       $(INSTALL_DIR) $(1)/etc/nginx/module.d
        $(INSTALL_DIR) $(1)/etc/nginx/conf.d
        $(INSTALL_DATA) $(addprefix $(PKG_INSTALL_DIR)/etc/nginx/,$(config_files)) $(1)/etc/nginx/
        $(INSTALL_DIR) $(1)/etc/init.d