rdma/siw: addition to kernel build environment
authorBernard Metzler <bmt@zurich.ibm.com>
Thu, 20 Jun 2019 16:21:33 +0000 (18:21 +0200)
committerJason Gunthorpe <jgg@mellanox.com>
Tue, 2 Jul 2019 20:03:41 +0000 (17:03 -0300)
Broken up commit to add the Soft iWarp RDMA driver.

Signed-off-by: Bernard Metzler <bmt@zurich.ibm.com>
Signed-off-by: Jason Gunthorpe <jgg@mellanox.com>
MAINTAINERS
drivers/infiniband/Kconfig
drivers/infiniband/sw/Makefile
drivers/infiniband/sw/siw/Kconfig [new file with mode: 0644]
drivers/infiniband/sw/siw/Makefile [new file with mode: 0644]

index 83a62b911692cafdf74aa41e2fe9dea7ddb5f4ed..6d2de0c1520e10391475a686585cf3171b6f8ffc 100644 (file)
@@ -14558,6 +14558,13 @@ M:     Chris Boot <bootc@bootc.net>
 S:     Maintained
 F:     drivers/leds/leds-net48xx.c
 
+SOFT-IWARP DRIVER (siw)
+M:     Bernard Metzler <bmt@zurich.ibm.com>
+L:     linux-rdma@vger.kernel.org
+S:     Supported
+F:     drivers/infiniband/sw/siw/
+F:     include/uapi/rdma/siw-abi.h
+
 SOFT-ROCE DRIVER (rxe)
 M:     Moni Shoua <monis@mellanox.com>
 L:     linux-rdma@vger.kernel.org
index 42af4cd40ba207045ff475f85112f88a5df2e7b1..f277cb7aea29ec95558fd5b7dd3a44b96e211650 100644 (file)
@@ -96,6 +96,7 @@ source "drivers/infiniband/hw/hfi1/Kconfig"
 source "drivers/infiniband/hw/qedr/Kconfig"
 source "drivers/infiniband/sw/rdmavt/Kconfig"
 source "drivers/infiniband/sw/rxe/Kconfig"
+source "drivers/infiniband/sw/siw/Kconfig"
 endif
 
 source "drivers/infiniband/ulp/ipoib/Kconfig"
index ab48a9b60844e9424771245c328630236e5e1d71..68e0230f8f3113e841e0889aa94983cd8a828838 100644 (file)
@@ -1,3 +1,4 @@
 # SPDX-License-Identifier: GPL-2.0-only
 obj-$(CONFIG_INFINIBAND_RDMAVT)                += rdmavt/
 obj-$(CONFIG_RDMA_RXE)                 += rxe/
+obj-$(CONFIG_RDMA_SIW)                 += siw/
diff --git a/drivers/infiniband/sw/siw/Kconfig b/drivers/infiniband/sw/siw/Kconfig
new file mode 100644 (file)
index 0000000..94f6841
--- /dev/null
@@ -0,0 +1,17 @@
+config RDMA_SIW
+       tristate "Software RDMA over TCP/IP (iWARP) driver"
+       depends on INET && INFINIBAND && CRYPTO_CRC32
+       help
+       This driver implements the iWARP RDMA transport over
+       the Linux TCP/IP network stack. It enables a system with a
+       standard Ethernet adapter to interoperate with a iWARP
+       adapter or with another system running the SIW driver.
+       (See also RXE which is a similar software driver for RoCE.)
+
+       The driver interfaces with the Linux RDMA stack and
+       implements both a kernel and user space RDMA verbs API.
+       The user space verbs API requires a support
+       library named libsiw which is loaded by the generic user
+       space verbs API, libibverbs. To implement RDMA over
+       TCP/IP, the driver further interfaces with the Linux
+       in-kernel TCP socket layer.
diff --git a/drivers/infiniband/sw/siw/Makefile b/drivers/infiniband/sw/siw/Makefile
new file mode 100644 (file)
index 0000000..f5f7e38
--- /dev/null
@@ -0,0 +1,11 @@
+obj-$(CONFIG_RDMA_SIW) += siw.o
+
+siw-y := \
+       siw_cm.o \
+       siw_cq.o \
+       siw_main.o \
+       siw_mem.o \
+       siw_qp.o \
+       siw_qp_tx.o \
+       siw_qp_rx.o \
+       siw_verbs.o