Successfully exit from the postinst script if the /etc/services entry already exists...
authorFlorian Fainelli <florian@openwrt.org>
Sat, 8 Mar 2008 09:32:28 +0000 (09:32 +0000)
committerFlorian Fainelli <florian@openwrt.org>
Sat, 8 Mar 2008 09:32:28 +0000 (09:32 +0000)
SVN-Revision: 10568

net/openntpd/Makefile

index 1629957f8cd4578597828ecfeeaa355b8745e24d..ba7e847e3da1a303e202ca77bc3b11590a5ca7c1 100644 (file)
@@ -73,7 +73,7 @@ if [ -z "$$(grep ^\\$${name}: $${IPKG_INSTROOT}/etc/passwd)" ]; then
 fi
 
 grep -q '^ntp[[:space:]]*123/udp' $${IPKG_INSTROOT}/etc/services 2>/dev/null
-[ $$? -ne 0 ] && echo "ntp       123/udp" >>$${IPKG_INSTROOT}/etc/services
+[ $$? -ne 0 ] && echo "ntp       123/udp" >>$${IPKG_INSTROOT}/etc/services || exit 0
 endef
 
 define Build/Configure