opencv: remove
authorRosen Penev <rosenp@gmail.com>
Sat, 7 Mar 2020 02:45:33 +0000 (18:45 -0800)
committerRosen Penev <rosenp@gmail.com>
Sat, 7 Mar 2020 02:45:33 +0000 (18:45 -0800)
This package is unmaintained. It also seems to be unused.

Signed-off-by: Rosen Penev <rosenp@gmail.com>
libs/opencv/Makefile [deleted file]
libs/opencv/README.md [deleted file]

diff --git a/libs/opencv/Makefile b/libs/opencv/Makefile
deleted file mode 100644 (file)
index e7267e1..0000000
+++ /dev/null
@@ -1,71 +0,0 @@
-#
-# Copyright (C) 2013-2014 wrtnode.com
-# Copyright (C) 2015-2016 OpenWrt.org
-#
-# This is free software, licensed under the GNU General Public License v2.
-# See /LICENSE for more information.
-#
-
-include $(TOPDIR)/rules.mk
-
-PKG_NAME:=opencv
-PKG_VERSION:=4.1.2
-PKG_RELEASE:=1
-
-PKG_SOURCE_PROTO:=git
-PKG_SOURCE_URL:=https://github.com/opencv/opencv
-PKG_SOURCE_VERSION:=$(PKG_VERSION)
-PKG_MIRROR_HASH:=1bd1cad4fa5c8f21499a45869fea40b7886026c048129a01be87b092178258c1
-
-PKG_MAINTAINER:=
-PKG_LICENSE:=BSD-3-Clause
-PKG_LICENSE_FILES:=LICENSE
-
-CMAKE_INSTALL:=1
-CMAKE_BINARY_SUBDIR:=build
-PKG_BUILD_PARALLEL:=1
-PKG_USE_MIPS16:=0
-
-include $(INCLUDE_DIR)/package.mk
-include $(INCLUDE_DIR)/cmake.mk
-
-define Package/opencv/Default/description
- OpenCV (Open Source Computer Vision Library) is an open source computer
- vision and machine learning software library. OpenCV was built to provide
- a common infrastructure for computer vision applications and to accelerate
- the use of machine perception in the commercial products. Being a
- BSD-licensed product, OpenCV makes it easy for businesses to utilize
- and modify the code.
-endef
-
-define Package/opencv
-  SECTION:=libs
-  CATEGORY:=Libraries
-  TITLE:=OpenCV
-  URL:=https://opencv.org/
-  DEPENDS:=+libpthread +librt +libatomic +libstdcpp +zlib +libjpeg +libwebp
-endef
-
-CMAKE_OPTIONS += \
-       -DBUILD_opencv_gpu:BOOL=OFF \
-       -DWITH_1394:BOOL=OFF -DBUILD_opencv_stitching:BOOL=OFF \
-       -DBUILD_opencv_superres:BOOL=OFF -DBUILD_opencv_ts:BOOL=OFF \
-       -DBUILD_opencv_highgui:BOOL=OFF \
-       -DBUILD_opencv_videostab:BOOL=OFF \
-       -DWITH_FFMPEG:BOOL=OFF \
-       -DWITH_GSTREAMER:BOOL=OFF \
-       -DWITH_LIBV4L:BOOL=OFF \
-       -DWITH_PNG:BOOL=OFF \
-       -DWITH_GTK:BOOL=OFF \
-       -DWITH_TIFF:BOOL=OFF \
-       -DCMAKE_VERBOSE:BOOL=OFF \
-       -DENABLE_PRECOMPILED_HEADERS=OFF
-
-TARGET_LDFLAGS += -latomic
-
-define Package/opencv/install
-       $(INSTALL_DIR) $(1)/usr/lib
-       $(CP) $(PKG_INSTALL_DIR)/usr/lib/libopencv* $(1)/usr/lib/
-endef
-
-$(eval $(call BuildPackage,opencv))
diff --git a/libs/opencv/README.md b/libs/opencv/README.md
deleted file mode 100644 (file)
index a5cdcdd..0000000
+++ /dev/null
@@ -1,23 +0,0 @@
-Introduction
-===
-
-#### OpenCV: Open Source Computer Vision Library.OpenCV is based on (open source) issued cross-platform computer vision library, you can run on Linux, Windows and Mac OS operating systems.
-
-#### Resources
-
-* Homepage: <http://opencv.org>
-* Docs: <http://docs.opencv.org>
-* Q&A forum: <http://answers.opencv.org>
-* Issue tracking: <http://code.opencv.org>
-
-#### Contributing
-
-Please read before starting work on a pull request: <http://code.opencv.org/projects/opencv/wiki/How_to_contribute>
-
-Summary of guidelines:
-
-* One pull request per issue;
-* Choose the right base branch;
-* Include tests and documentation;
-* Clean up "oops" commits before submitting;
-* Follow the coding style guide.