faad2: Remove uClibc hack
authorRosen Penev <rosenp@gmail.com>
Sun, 5 May 2019 21:29:03 +0000 (14:29 -0700)
committerRosen Penev <rosenp@gmail.com>
Sun, 5 May 2019 23:07:32 +0000 (16:07 -0700)
OpenWrt uses uClibc-ng now, and it seems that these are no longer needed
as it seems faad2 automatically renames these functions.

Signed-off-by: Rosen Penev <rosenp@gmail.com>
libs/faad2/Makefile

index 9e75283ea4a10834469e5ba9740b53ffca1b7dab..77027b5be063efdfd71fb3c37b9fbb12d2914538 100644 (file)
@@ -7,7 +7,7 @@ include $(TOPDIR)/rules.mk
 
 PKG_NAME:=faad2
 PKG_VERSION:=2.8.8
-PKG_RELEASE:=1
+PKG_RELEASE:=2
 
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
 PKG_SOURCE_URL:=@SF/faac/faad2-src/$(PKG_NAME)-2.8.0
@@ -64,10 +64,6 @@ ifeq ($(CONFIG_SOFT_FLOAT),y)
        CONFIGURE_ARGS+= -nfp
 endif
 
-ifeq ($(CONFIG_USE_UCLIBC),y)
-       CONFIGURE_VARS+= CPPFLAGS="-fno-builtin-cos -fno-builtin-sin -fno-builtin-log"
-endif
-
 define Build/InstallDev
        $(INSTALL_DIR) $(1)/usr/include
        $(CP) $(PKG_INSTALL_DIR)/usr/include/*.h $(1)/usr/include