nginx-util: allow building with OpenSSL 3.0
authorEneas U de Queiroz <cotequeiroz@gmail.com>
Thu, 9 Feb 2023 14:25:47 +0000 (11:25 -0300)
committerEneas U de Queiroz <cotequeiroz@gmail.com>
Thu, 16 Feb 2023 13:28:52 +0000 (10:28 -0300)
Add -Wno-error=deprecated-declarations to CFLAGS to allow usage of
deprecated API.

Signed-off-by: Eneas U de Queiroz <cotequeiroz@gmail.com>
net/nginx-util/Makefile

index f5bb54d11469fe0e0e0a830bb92bd5167fc6128e..2ff4da194426cd3791ca77061518cd1b298e2efc 100644 (file)
@@ -2,7 +2,7 @@ include $(TOPDIR)/rules.mk
 
 PKG_NAME:=nginx-util
 PKG_VERSION:=1.6
-PKG_RELEASE:=$(AUTORELEASE)
+PKG_RELEASE:=15
 PKG_MAINTAINER:=Peter Stadler <peter.stadler@student.uibk.ac.at>
 
 include $(INCLUDE_DIR)/package.mk
@@ -11,6 +11,7 @@ include $(INCLUDE_DIR)/cmake.mk
 CMAKE_OPTIONS+= -DUBUS=y
 CMAKE_OPTIONS+= -DVERSION=$(PKG_VERSION)
 
+TARGET_CFLAGS+= -Wno-error=deprecated-declarations
 
 define Package/nginx-ssl-util/default
   SECTION:=net