modemmanager: report events for virtual netdevices
authorDaniele Palmas <dnlplm@gmail.com>
Tue, 27 Feb 2024 11:15:40 +0000 (12:15 +0100)
committerDaniele Palmas <dnlplm@gmail.com>
Wed, 6 Mar 2024 09:16:21 +0000 (10:16 +0100)
Virtual netdevices created for multiplexing should not be skipped
when reporting events, otherwise it is not possible to setup the
data connection.

Add these exceptions in mm_report_event function.

Signed-off-by: Daniele Palmas <dnlplm@gmail.com>
net/modemmanager/Makefile
net/modemmanager/files/usr/share/ModemManager/modemmanager.common

index 97f8dce06a60a74e28c1a1489b2774458cce4377..8759cd4054e4606cd0cb5a94949d97cf1ea4d098 100644 (file)
@@ -9,7 +9,7 @@ include $(TOPDIR)/rules.mk
 
 PKG_NAME:=modemmanager
 PKG_SOURCE_VERSION:=1.22.0
-PKG_RELEASE:=11
+PKG_RELEASE:=12
 
 PKG_SOURCE_PROTO:=git
 PKG_SOURCE_URL:=https://gitlab.freedesktop.org/mobile-broadband/ModemManager.git
index ab5f92b982292d8abebd7c3ec1fea961ea465817..0315673d88bf9f597f4a8d9d578339337b9bbcde 100644 (file)
@@ -130,7 +130,20 @@ mm_report_event() {
        virtual="$(echo "$sysfspath" | cut -d'/' -f4)"
        [ "$virtual" = "virtual" ] && {
                mm_log "debug" "sysfspath is a virtual device ($sysfspath)"
-               return
+               case "$name" in
+                       "qmapmux"*)
+                               mm_log "debug" "rmnet netdevice $name"
+                               ;;
+                       "qmimux"*)
+                               mm_log "debug" "qmi_wwan qmap netdevice $name"
+                               ;;
+                       "mbimmux"*)
+                               mm_log "debug" "mbim vlan netdevice $name"
+                               ;;
+                       *)
+                               return
+                               ;;
+               esac
        }
 
        # Track/untrack events in cache