fix shfs-utils build
authorNicolas Thill <nico@openwrt.org>
Fri, 23 Sep 2005 22:15:43 +0000 (22:15 +0000)
committerNicolas Thill <nico@openwrt.org>
Fri, 23 Sep 2005 22:15:43 +0000 (22:15 +0000)
SVN-Revision: 1985

openwrt/package/shfs/Config.in
openwrt/package/shfs/Makefile

index a464a4137e406db1030457bd616e92ff5f70cea2..d9f052754bcda9916740c3e1ed335a82369bcd7d 100644 (file)
@@ -5,10 +5,11 @@ config BR2_PACKAGE_SHFS
 
 
 config BR2_PACKAGE_SHFS_UTILS
-       select BR2_PACKAGE_KMOD_SHFS
        prompt "shfs-utils - ShFS mount/umount utilities"
        tristate
        default m if CONFIG_DEVEL
+       select BR2_PACKAGE_SHFS
+       select BR2_PACKAGE_KMOD_SHFS
        help
          ShFS is a simple and easy to use Linux kernel module which 
          allows you to mount remote filesystems using a plain shell 
index 653bc1c4fd04e446f976c62d0e9affaf56a9753a..f87a63b418252b081a27ff5fc7de1120b3af9175 100644 (file)
@@ -28,10 +28,9 @@ $(PKG_BUILD_DIR)/.built:
                OFLAGS="$(TARGET_CFLAGS)" \
                CC="$(TARGET_CC)" \
                LINKER="$(TARGET_CC)" \
-               KERNEL="$(LINUX_VERSION)" \
                KERNEL_SOURCES="$(LINUX_DIR)" \
                ROOT="$(PKG_INSTALL_DIR)" \
-               all install
+               utils utils-install
        touch $@
 
 $(IPKG_SHFS_UTILS):