quota: fix compilation without sys/cdefs
authorRosen Penev <rosenp@gmail.com>
Mon, 10 Aug 2020 20:07:45 +0000 (13:07 -0700)
committerRosen Penev <rosenp@gmail.com>
Mon, 10 Aug 2020 22:30:53 +0000 (15:30 -0700)
sys/cdefs.h does not come included with musl. It's also deprecated.

Signed-off-by: Rosen Penev <rosenp@gmail.com>
utils/quota/Makefile
utils/quota/patches/010-cdefs.patch [new file with mode: 0644]

index 9633a79b8b844a64433b27fd49e8b25dc3f46039..49af89eb11661840bf8a7ce42222c2c477f8b319 100644 (file)
@@ -7,7 +7,7 @@ include $(TOPDIR)/rules.mk
 
 PKG_NAME:=quota
 PKG_VERSION:=4.05
-PKG_RELEASE:=2
+PKG_RELEASE:=3
 
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
 PKG_SOURCE_URL:=@SF/linuxquota
diff --git a/utils/quota/patches/010-cdefs.patch b/utils/quota/patches/010-cdefs.patch
new file mode 100644 (file)
index 0000000..a44978e
--- /dev/null
@@ -0,0 +1,18 @@
+--- a/quota.h
++++ b/quota.h
+@@ -1,7 +1,6 @@
+ #ifndef GUARD_QUOTA_H
+ #define GUARD_QUOTA_H
+-#include <sys/cdefs.h>
+ #include <sys/types.h>
+ #include <stdint.h>
+@@ -182,6 +181,6 @@ enum {
+       #endif
+ #endif
+-long quotactl __P((int, const char *, qid_t, caddr_t));
++long quotactl (int, const char *, qid_t, caddr_t);
+ #endif /* _QUOTA_ */