openthread-br: bump source version to 2024-11-20 and add missing dependencies
authorItay Shoshani <itai.sho@gmail.com>
Sat, 9 Nov 2024 22:30:40 +0000 (00:30 +0200)
committerStijn Tintel <stijn@linux-ipv6.be>
Mon, 25 Nov 2024 14:22:34 +0000 (16:22 +0200)
Bumping ot-br-posix that openthread-br is based on to latest code.
Due to some major changes required some more compilation flags, and in order to avoid the ot-br agent had to add some dependencies as well

Dependecies:
1. kmod-tun: otherwise the otbr fails to load and crashed immidiedtly

Compilation flags:
1. OTBR_NAT64, OT_NAT64_BORDER_ROUTING set to OFF: a temporary workaround to a compilation problem with openwrt, could be reverted once the issue here is fixed: openthread/ot-br-posix#2606
2. OT_TARGET_OPENWRT: wasn't assumed from OTBR_OPENWRT in some targets

Signed-off-by: Itay Shoshani <itai.sho@gmail.com>
net/openthread-br/Makefile

index d4df6e40b5186693d94ac013afb48beb9f8d3e9c..89536dac85de2a86da16509d8f189c7f8e8b1f1d 100644 (file)
@@ -4,13 +4,13 @@
 include $(TOPDIR)/rules.mk
 
 PKG_NAME:=openthread-br
-PKG_SOURCE_DATE:=2023-08-01
-PKG_SOURCE_VERSION:=1738d8cd8b42106c2ef1262fbbac2f06beab83ba
+PKG_SOURCE_DATE:=2024-11-20
+PKG_SOURCE_VERSION:=bd7bc77742920eba3b3801a410c3eba3372c98bb
 PKG_RELEASE:=1
 
 PKG_SOURCE_PROTO:=git
 PKG_SOURCE_URL=https://github.com/openthread/ot-br-posix.git
-PKG_MIRROR_HASH:=035925e78df115d4c08ca5ab50197855ce47d70ee5fb76caeef1c91e9d804f04
+PKG_MIRROR_HASH:=ca4352e527e38de26c8c4242ced5899e6fd1e4fea57d0dc4b2a6bd433e6b14b6
 
 PKG_MAINTAINER:=Stijn Tintel <stijn@linux-ipv6.be>
 PKG_LICENSE:=BSD-3-Clause
@@ -32,6 +32,7 @@ define Package/openthread-br
   SECTION:=net
   TITLE:=OpenThread Border Router
   DEPENDS:= \
+       +kmod-tun \
        +libblobmsg-json \
        +libjson-c \
        +libncurses \
@@ -57,12 +58,14 @@ CMAKE_OPTIONS += \
        -DOT_CHANNEL_MANAGER=ON \
        -DOT_CHANNEL_MONITOR=ON \
        -DOT_FIREWALL=OFF \
+       -DOT_NAT64_BORDER_ROUTING=OFF \
+       -DOT_TARGET_OPENWRT=ON \
        -DOTBR_BACKBONE_ROUTER=ON \
        -DOTBR_BORDER_ROUTING=ON \
        -DOTBR_DNSSD_DISCOVERY_PROXY=ON \
        -DOTBR_DUA_ROUTING=ON \
        -DOTBR_MDNS=mDNSResponder \
-       -DOTBR_NAT64=ON \
+       -DOTBR_NAT64=OFF \
        -DOTBR_OPENWRT=ON \
        -DOTBR_REST=ON \
        -DOTBR_SRP_ADVERTISING_PROXY=ON \