sparc: fix KBUILD_DEFCONFIG for ARCH=sparc32
authorMasahiro Yamada <yamada.masahiro@socionext.com>
Mon, 20 Aug 2018 17:08:28 +0000 (02:08 +0900)
committerDavid S. Miller <davem@davemloft.net>
Tue, 21 Aug 2018 19:41:12 +0000 (12:41 -0700)
As commit 5ba800962a80 ("kbuild: update ARCH alias info for sparc")
addressed, SPARC accepts ARCH=sparc32 as an alias.

However, arch/sparc/Makefile wrongly sets KBUILD_DEFCONFIG, then
sparc64_defconfig is chosen as the base configuration for ARCH=sparc32.

  $ make ARCH=sparc32 defconfig
  *** Default configuration is based on 'sparc64_defconfig'
  #
  # configuration written to .config
  #

Fix the logic to choose sparc64_defconfig only when ARCH=sparc64.

Signed-off-by: Masahiro Yamada <yamada.masahiro@socionext.com>
Signed-off-by: David S. Miller <davem@davemloft.net>
arch/sparc/Makefile

index 966a13d2b127e7c4933aaf561d90f47a36a8a67d..e32ef20de567702368bcfbfd7de371150aeedd5a 100644 (file)
@@ -9,10 +9,10 @@
 # Copyright (C) 1998 Jakub Jelinek (jj@ultra.linux.cz)
 
 # We are not yet configured - so test on arch
-ifeq ($(ARCH),sparc)
-        KBUILD_DEFCONFIG := sparc32_defconfig
-else
+ifeq ($(ARCH),sparc64)
         KBUILD_DEFCONFIG := sparc64_defconfig
+else
+        KBUILD_DEFCONFIG := sparc32_defconfig
 endif
 
 ifeq ($(CONFIG_SPARC32),y)