uboot-sunxi: make a distinction between H6 and A64 ATF builds
authorZoltan HERPAI <wigyori@uid0.hu>
Fri, 24 Apr 2020 07:38:56 +0000 (09:38 +0200)
committerZoltan HERPAI <wigyori@uid0.hu>
Fri, 24 Apr 2020 07:40:34 +0000 (09:40 +0200)
The A64 and the H6-based boards require a separate build of ATF.
Add a variable to cover this distinction.

Signed-off-by: Zoltan HERPAI <wigyori@uid0.hu>
package/boot/uboot-sunxi/Makefile

index 7f5afd48f152367543d2371efcb579f32cc8a551..caa1b21ac7d41582c42761199156fce78d3873e8 100644 (file)
@@ -31,6 +31,7 @@ define U-Boot/a64-olinuxino
   BUILD_DEVICES:=olimex_a64-olinuxino
   DEPENDS:=+PACKAGE_u-boot-olimex_a64-olinuxino:arm-trusted-firmware-sunxi
   UENV:=a64
+  ATF:=a64
 endef
 
 define U-Boot/a64-olinuxino-emmc
@@ -39,6 +40,7 @@ define U-Boot/a64-olinuxino-emmc
   BUILD_DEVICES:=olimex_a64-olinuxino-emmc
   DEPENDS:=+PACKAGE_u-boot-olimex_a64-olinuxino-emmc:arm-trusted-firmware-sunxi
   UENV:=a64
+  ATF:=a64
 endef
 
 define U-Boot/A10-OLinuXino-Lime
@@ -189,6 +191,7 @@ define U-Boot/orangepi_one_plus
   NAME:=Orange Pi One Plus (H6)
   DEPENDS:=+PACKAGE_u-boot-orangepi_one_plus:arm-trusted-firmware-sunxi
   BUILD_DEVICES:=xunlong_orangepi-one-plus
+  ATF:=h6
 endef
 
 define U-Boot/orangepi_pc
@@ -263,6 +266,7 @@ define U-Boot/sopine_baseboard
   BUILD_DEVICES:=pine64_sopine-baseboard
   DEPENDS:=+PACKAGE_u-boot-sopine_baseboard:arm-trusted-firmware-sunxi
   UENV:=a64
+  ATF:=a64
 endef
 
 
@@ -272,6 +276,7 @@ define U-Boot/orangepi_zero_plus
   BUILD_DEVICES:=xunlong_orangepi-zero-plus
   DEPENDS:=+PACKAGE_u-boot-orangepi_zero_plus:arm-trusted-firmware-sunxi
   UENV:=a64
+  ATF:=a64
 endef
 
 define U-Boot/orangepi_pc2
@@ -280,6 +285,7 @@ define U-Boot/orangepi_pc2
   BUILD_DEVICES:=xunlong_orangepi-pc2
   DEPENDS:=+PACKAGE_u-boot-orangepi_pc2:arm-trusted-firmware-sunxi
   UENV:=a64
+  ATF:=a64
 endef
 
 define U-Boot/Bananapi_M2_Ultra
@@ -333,7 +339,7 @@ UBOOT_TARGETS := \
 UBOOT_CONFIGURE_VARS += USE_PRIVATE_LIBGCC=yes
 
 UBOOT_MAKE_FLAGS += \
-       BL31=$(STAGING_DIR_IMAGE)/bl31.bin
+       BL31=$(STAGING_DIR_IMAGE)/bl31_$(ATF).bin
 
 define Build/InstallDev
        $(INSTALL_DIR) $(STAGING_DIR_IMAGE)