uboot-sunxi: add ATF variable for specifying which flavour to use
authorZoltan HERPAI <wigyori@uid0.hu>
Wed, 29 Apr 2020 09:02:27 +0000 (11:02 +0200)
committerZoltan HERPAI <wigyori@uid0.hu>
Sun, 24 Jan 2021 23:06:38 +0000 (00:06 +0100)
In preparation for H6 support (which requires a separate ATF blob), add
an envvar to the A64 boards specifying which ATF blob to use.

Signed-off-by: Zoltan HERPAI <wigyori@uid0.hu>
package/boot/uboot-sunxi/Makefile

index 859a06019b046ec43eaa27d15d3988239a76aba6..28be47e278f0c4be3abdc7f4a0e9f74a2444994f 100644 (file)
@@ -31,6 +31,7 @@ define U-Boot/a64-olinuxino
   BUILD_DEVICES:=olimex_a64-olinuxino
   DEPENDS:=+PACKAGE_u-boot-olimex_a64-olinuxino:arm-trusted-firmware-sunxi
   UENV:=a64
+  ATF:=a64
 endef
 
 define U-Boot/a64-olinuxino-emmc
@@ -39,6 +40,7 @@ define U-Boot/a64-olinuxino-emmc
   BUILD_DEVICES:=olimex_a64-olinuxino-emmc
   DEPENDS:=+PACKAGE_u-boot-olimex_a64-olinuxino-emmc:arm-trusted-firmware-sunxi
   UENV:=a64
+  ATF:=a64
 endef
 
 define U-Boot/A10-OLinuXino-Lime
@@ -240,6 +242,7 @@ define U-Boot/nanopi_neo_plus2
   BUILD_DEVICES:=friendlyarm_nanopi-neo-plus2
   DEPENDS:=+PACKAGE_u-boot-nanopi_neo_plus2:arm-trusted-firmware-sunxi
   UENV:=a64
+  ATF:=a64
 endef
 
 define U-Boot/nanopi_neo2
@@ -248,6 +251,7 @@ define U-Boot/nanopi_neo2
   BUILD_DEVICES:=friendlyarm_nanopi-neo2
   DEPENDS:=+PACKAGE_u-boot-nanopi_neo2:arm-trusted-firmware-sunxi
   UENV:=a64
+  ATF:=a64
 endef
 
 define U-Boot/pine64_plus
@@ -256,6 +260,7 @@ define U-Boot/pine64_plus
   BUILD_DEVICES:=pine64_pine64-plus
   DEPENDS:=+PACKAGE_u-boot-pine64_plus:arm-trusted-firmware-sunxi
   UENV:=a64
+  ATF:=a64
 endef
 
 define U-Boot/bananapi_m2_plus_h3
@@ -270,6 +275,7 @@ define U-Boot/sopine_baseboard
   BUILD_DEVICES:=pine64_sopine-baseboard
   DEPENDS:=+PACKAGE_u-boot-sopine_baseboard:arm-trusted-firmware-sunxi
   UENV:=a64
+  ATF:=a64
 endef
 
 
@@ -279,6 +285,7 @@ define U-Boot/orangepi_zero_plus
   BUILD_DEVICES:=xunlong_orangepi-zero-plus
   DEPENDS:=+PACKAGE_u-boot-orangepi_zero_plus:arm-trusted-firmware-sunxi
   UENV:=a64
+  ATF:=a64
 endef
 
 define U-Boot/orangepi_pc2
@@ -287,6 +294,7 @@ define U-Boot/orangepi_pc2
   BUILD_DEVICES:=xunlong_orangepi-pc2
   DEPENDS:=+PACKAGE_u-boot-orangepi_pc2:arm-trusted-firmware-sunxi
   UENV:=a64
+  ATF:=a64
 endef
 
 define U-Boot/Bananapi_M2_Ultra
@@ -342,7 +350,7 @@ UBOOT_TARGETS := \
 UBOOT_CONFIGURE_VARS += USE_PRIVATE_LIBGCC=yes
 
 UBOOT_MAKE_FLAGS += \
-       BL31=$(STAGING_DIR_IMAGE)/bl31.bin
+       BL31=$(STAGING_DIR_IMAGE)/bl31_$(ATF).bin
 
 define Build/InstallDev
        $(INSTALL_DIR) $(STAGING_DIR_IMAGE)