Revert "openthread-br: fix actually building"
authorStijn Tintel <stijn@linux-ipv6.be>
Sat, 30 Sep 2023 03:04:55 +0000 (06:04 +0300)
committerStijn Tintel <stijn@linux-ipv6.be>
Sun, 29 Oct 2023 03:52:46 +0000 (05:52 +0200)
This reverts commit 5958fd068fd0eb96a59c1758fd1906f472981ad5.

net/openthread-br/Makefile
net/openthread-br/patches/100-rest-support-deleting-the-dataset.patch

index d5b61b1e1391d5e19451c135d8c4ab932fca2d49..1b42cceee555b4e7d1012fafd6abe428c6bec675 100644 (file)
@@ -6,7 +6,7 @@ include $(TOPDIR)/rules.mk
 PKG_NAME:=openthread-br
 PKG_SOURCE_DATE:=2023-08-01
 PKG_SOURCE_VERSION:=1738d8cd8b42106c2ef1262fbbac2f06beab83ba
-PKG_RELEASE:=2
+PKG_RELEASE:=1
 
 PKG_SOURCE_PROTO:=git
 PKG_SOURCE_URL=https://github.com/openthread/ot-br-posix.git
@@ -74,9 +74,7 @@ CMAKE_OPTIONS += \
        -DOTBR_SRP_SERVER_AUTO_ENABLE:BOOL=ON \
        -DOTBR_TREL:BOOL=ON
 
-TARGET_CFLAGS += -DOPENTHREAD_POSIX_CONFIG_DAEMON_SOCKET_BASENAME=\\\"/var/run/openthread-%s\\\" \
-                -I$(STAGING_DIR)/usr/include/mdns \
-                -L$(STAGING_DIR)/usr/lib/mdns
+TARGET_CFLAGS += -DOPENTHREAD_POSIX_CONFIG_DAEMON_SOCKET_BASENAME=\\\"/var/run/openthread-%s\\\"
 
 define Package/luci-app-openthread/install
        $(INSTALL_DIR) \
@@ -96,6 +94,7 @@ endef
 
 define Package/openthread-br/install
        $(INSTALL_DIR) \
+               $(1)/etc/init.d \
                $(1)/lib/netifd/proto \
                $(1)/usr/sbin \
                $(1)/var/lib/thread
index 5605acb154023b1be982bd3625f99aada6cd06d2..014c306f3b4daf03f4f3d6a7a77bf1978ad5ecd6 100644 (file)
@@ -16,6 +16,8 @@ otDatasetCreateNewNetwork).
  src/rest/resource.hpp |  1 +
  3 files changed, 57 insertions(+)
 
+diff --git a/src/rest/openapi.yaml b/src/rest/openapi.yaml
+index 2ba2a4dd56..2edc4af29a 100644
 --- a/src/rest/openapi.yaml
 +++ b/src/rest/openapi.yaml
 @@ -248,6 +248,18 @@ paths:
@@ -53,6 +55,8 @@ otDatasetCreateNewNetwork).
  components:
    schemas:
      LeaderData:
+diff --git a/src/rest/resource.cpp b/src/rest/resource.cpp
+index a60e9d9483..829835341a 100644
 --- a/src/rest/resource.cpp
 +++ b/src/rest/resource.cpp
 @@ -767,12 +767,47 @@ exit:
@@ -103,6 +107,8 @@ otDatasetCreateNewNetwork).
      case HttpMethod::kGet:
          GetDataset(aDatasetType, aRequest, aResponse);
          break;
+diff --git a/src/rest/resource.hpp b/src/rest/resource.hpp
+index d79085dbfc..362e501471 100644
 --- a/src/rest/resource.hpp
 +++ b/src/rest/resource.hpp
 @@ -150,6 +150,7 @@ private:
@@ -113,3 +119,6 @@ otDatasetCreateNewNetwork).
  
      void DeleteOutDatedDiagnostic(void);
      void UpdateDiag(std::string aKey, std::vector<otNetworkDiagTlv> &aDiag);
+-- 
+2.41.0
+