projects
/
feed
/
packages.git
/ commitdiff
commit
grep
author
committer
pickaxe
?
search:
re
summary
|
shortlog
|
log
|
commit
| commitdiff |
tree
raw
|
patch
| inline |
side by side
(parent:
0887897
)
expat: add host build
author
Daniel Golle
<daniel@makrotopia.org>
Wed, 24 Nov 2021 01:33:20 +0000
(
01:33
+0000)
committer
Daniel Golle
<daniel@makrotopia.org>
Wed, 24 Nov 2021 01:34:23 +0000
(
01:34
+0000)
mesa in the video feed requires expat/host. Provide host build to
allow mesa to build.
Signed-off-by: Daniel Golle <daniel@makrotopia.org>
libs/expat/Makefile
patch
|
blob
|
history
diff --git
a/libs/expat/Makefile
b/libs/expat/Makefile
index 7e8baf4e756ce143329d60da80a38677f1062bf2..4bacb8e915499a16f7d95fd5491e07c3dbe2e88c 100644
(file)
--- a/
libs/expat/Makefile
+++ b/
libs/expat/Makefile
@@
-21,6
+21,7
@@
PKG_CPE_ID:=cpe:/a:libexpat:expat
CMAKE_INSTALL:=1
include $(INCLUDE_DIR)/package.mk
+include $(INCLUDE_DIR)/host-build.mk
include $(INCLUDE_DIR)/cmake.mk
define Package/libexpat
@@
-51,4
+52,5
@@
define Package/libexpat/install
$(CP) $(PKG_INSTALL_DIR)/usr/lib/libexpat.so.* $(1)/usr/lib/
endef
+$(eval $(call HostBuild))
$(eval $(call BuildPackage,libexpat))