bcm27xx-eeprom: update to v2022.04.26-138a1
authorÁlvaro Fernández Rojas <noltari@gmail.com>
Tue, 17 May 2022 14:22:56 +0000 (16:22 +0200)
committerÁlvaro Fernández Rojas <noltari@gmail.com>
Tue, 17 May 2022 14:27:45 +0000 (16:27 +0200)
Git compare: https://github.com/raspberrypi/rpi-eeprom/compare/47976e4409c6999a8e211976c75c60a97c90275c...v2022.04.26-138a1

Signed-off-by: Álvaro Fernández Rojas <noltari@gmail.com>
utils/bcm27xx-eeprom/Makefile
utils/bcm27xx-eeprom/patches/0003-rpi-eeprom-update-change-default-include-path.patch
utils/bcm27xx-eeprom/patches/0004-rpi-eeprom-update-chmod-silent-f-is-not-supported.patch
utils/bcm27xx-eeprom/patches/0005-rpi-eeprom-config-change-default-text-editor.patch

index 4d21769fdad90077e1f44ba6445ef74159d66d92..b114ee11ab3cdf3593a6ffde0a643f0d22bb11e2 100644 (file)
@@ -1,12 +1,12 @@
 include $(TOPDIR)/rules.mk
 
 PKG_NAME:=bcm27xx-eeprom
-PKG_VERSION:=47976e4409c6999a8e211976c75c60a97c90275c
-PKG_RELEASE:=1
+PKG_VERSION:=v2022.04.26-138a1
+PKG_RELEASE:=$(AUTORELEASE)
 
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
 PKG_SOURCE_URL:=https://codeload.github.com/raspberrypi/rpi-eeprom/tar.gz/$(PKG_VERSION)?
-PKG_HASH:=fe67e174d897c6e29549129522c2fbce2404142e098c3c809c2a3b26b5708055
+PKG_HASH:=7c54839e68f226c5853fb63c8a1539b729d84b2e6bac311a51766c601d10a413
 
 PKG_LICENSE:=BSD-3-Clause Custom
 PKG_LICENSE_FILES:=LICENSE
@@ -43,6 +43,7 @@ define Package/bcm27xx-eeprom/install
 
        $(INSTALL_DIR) $(1)/usr/bin
        $(INSTALL_BIN) $(PKG_BUILD_DIR)/rpi-eeprom-config $(1)/usr/bin
+       $(INSTALL_BIN) $(PKG_BUILD_DIR)/rpi-eeprom-digest $(1)/usr/bin
        $(INSTALL_BIN) $(PKG_BUILD_DIR)/rpi-eeprom-update $(1)/usr/bin
 
        $(INSTALL_DIR) $(1)/lib/firmware/raspberrypi/bootloader
index 51afd53930114db43495a9e9e253b8ec2e254f14..535d07ebef63682cad82bae6eb85f90109f9ab6d 100644 (file)
@@ -24,7 +24,7 @@ Signed-off-by: Álvaro Fernández Rojas <noltari@gmail.com>
  fi
  
  LOCAL_MODE=0
-@@ -400,7 +400,7 @@ The system should then boot normally.
+@@ -380,7 +380,7 @@ The system should then boot normally.
  
  If /boot does not correspond to the boot partition and this
  is not a NOOBS system, then the mount point for BOOTFS should be defined
@@ -33,7 +33,7 @@ Signed-off-by: Álvaro Fernández Rojas <noltari@gmail.com>
  
  A backup of the current EEPROM config file is written to ${FIRMWARE_BACKUP_DIR}
  before applying the update.
-@@ -433,7 +433,7 @@ Options:
+@@ -413,7 +413,7 @@ Options:
     -u Install the specified VL805 (USB EEPROM) image file.
  
  Environment:
index 0f39bfd791e9678e72961ff7efda8e5964661c7f..5872f12da9e204dee9ce80a0cfcd68a4d3aa9ce0 100644 (file)
@@ -13,7 +13,7 @@ Signed-off-by: Álvaro Fernández Rojas <noltari@gmail.com>
 
 --- a/rpi-eeprom-update
 +++ b/rpi-eeprom-update
-@@ -223,7 +223,7 @@ applyRecoveryUpdate()
+@@ -200,7 +200,7 @@ applyRecoveryUpdate()
                  || die "Failed to copy ${TMP_EEPROM_IMAGE} to ${BOOTFS}"
  
          # For NFS mounts ensure that the files are readable to the TFTP user
@@ -22,7 +22,7 @@ Signed-off-by: Álvaro Fernández Rojas <noltari@gmail.com>
                  || die "Failed to set permissions on eeprom update files"
     fi
  
-@@ -235,7 +235,7 @@ applyRecoveryUpdate()
+@@ -211,7 +211,7 @@ applyRecoveryUpdate()
                  || die "Failed to copy ${VL805_UPDATE_IMAGE} to ${BOOTFS}/vl805.bin"
  
          # For NFS mounts ensure that the files are readable to the TFTP user
index 66e890aadf05fb7c4b6467a075c1b2bc4bf3845b..6feb7602c7b615db1726c09760c14874b5f8ac5c 100644 (file)
@@ -1,6 +1,6 @@
 --- a/rpi-eeprom-config
 +++ b/rpi-eeprom-config
-@@ -129,8 +129,8 @@ def edit_config(eeprom=None):
+@@ -166,8 +166,8 @@ def edit_config(eeprom=None):
      """
      Implements something like 'git commit' for editing EEPROM configs.
      """
@@ -11,7 +11,7 @@
      if 'EDITOR' in os.environ:
          editor = os.environ['EDITOR']
  
-@@ -317,7 +317,7 @@ Operating modes:
+@@ -428,7 +428,7 @@ Operating modes:
  
     To cancel the pending update run 'sudo rpi-eeprom-update -r'
  
@@ -19,4 +19,4 @@
 +   The default text editor is vi and may be overridden by setting the 'EDITOR'
     environment variable and passing '-E' to 'sudo' to preserve the environment.
  
- See 'rpi-eeprom-update -h' for more information about the available EEPROM
+ 6. Signing the bootloader config file.