sumo: fix compilation when gtest is present
authorRosen Penev <rosenp@gmail.com>
Sat, 19 Jun 2021 07:36:51 +0000 (00:36 -0700)
committerRosen Penev <rosenp@gmail.com>
Sat, 19 Jun 2021 21:10:20 +0000 (14:10 -0700)
Removes cmake check for gtest.

Signed-off-by: Rosen Penev <rosenp@gmail.com>
utils/sumo/patches/010-gtest.patch [new file with mode: 0644]

diff --git a/utils/sumo/patches/010-gtest.patch b/utils/sumo/patches/010-gtest.patch
new file mode 100644 (file)
index 0000000..66a941c
--- /dev/null
@@ -0,0 +1,10 @@
+--- a/CMakeLists.txt
++++ b/CMakeLists.txt
+@@ -339,7 +339,6 @@ if (SUMO_LIBRARIES AND WIN32)
+     file(GLOB TEXTTEST_EXECUTABLE "${SUMO_LIBRARIES}/TextTest-*/texttest.exe")
+ else ()
+     # for Linux and Mac only
+-    find_package(GTest)
+ endif ()
+ find_package(XercesC REQUIRED)