privoxy: fix uci configuration parsing after upstream OpenWrt changes
authorJo-Philipp Wich <jo@mein.io>
Sat, 21 Jul 2018 19:16:03 +0000 (21:16 +0200)
committerJo-Philipp Wich <jo@mein.io>
Wed, 1 Aug 2018 07:29:55 +0000 (09:29 +0200)
OpenWrt changed the way the uci shell parsing functions deal with list
configuration items.

This change broke the generation of the privoxy runtime configuration
because no callbacks were emitted anymore.

Fix the problem by defining a list_cb() that simply calls the existing
option_cb() to deal with list item values.

Ref: c9c0fc28a9 ("base-files: fix UCI config parsing and callback handling")
Ref: https://forum.lede-project.org/t/openwrt-snapshot-privoxy-error/15919
Signed-off-by: Jo-Philipp Wich <jo@mein.io>
(cherry picked from commit 3113d62393fcd364a402aae55139eba4bf38fab8)

net/privoxy/Makefile
net/privoxy/files/privoxy.init

index b71251d077b2beab40fae395741d9a6ecadd33be..605d09922c574ac29db1dbbce44995fe1237510b 100644 (file)
@@ -9,7 +9,7 @@ include $(TOPDIR)/rules.mk
 
 PKG_NAME:=privoxy
 PKG_VERSION:=3.0.26
-PKG_RELEASE:=3
+PKG_RELEASE:=4
 
 PKG_SOURCE:=privoxy-$(PKG_VERSION)-stable-src.tar.gz
 PKG_SOURCE_URL:=@SF/ijbswa
index b2592b35a90a7f801b927b77594f4df464806637..d9c92fb7dab5805287f70f02b338c879f3870af6 100644 (file)
@@ -40,6 +40,11 @@ _uci2conf() {
                                                ;;
                                esac
                        }
+
+                       list_cb()
+                       {
+                               option_cb "$@"
+                       }
                fi
        }