zmq: fix gcc 13 errors
authorOskari Rauta <oskari.rauta@gmail.com>
Fri, 19 May 2023 18:14:59 +0000 (21:14 +0300)
committerRosen Penev <rosenp@gmail.com>
Sat, 20 May 2023 10:00:04 +0000 (13:00 +0300)
gcc 13 compatibility patch is from alpine linux.
https://git.alpinelinux.org/aports/tree/main/zeromq/gcc13.patch

fixes #20972

I also renamed one of patches, so patch filenames are more unified.

Signed-off-by: Oskari Rauta <oskari.rauta@gmail.com>
libs/zmq/Makefile
libs/zmq/patches/0001-fix-openpgm-linking-for-zeromq.patch [deleted file]
libs/zmq/patches/010-fix-openpgm-linking-for-zeromq.patch [new file with mode: 0644]
libs/zmq/patches/030-gcc13-compatibility.patch [new file with mode: 0644]

index 25266b981def782f8bd0e0649c3d2e190a2e5777..0c3a7f3e185dc4105051d5cd73119036470a4f3b 100644 (file)
@@ -11,7 +11,7 @@ include $(TOPDIR)/rules.mk
 
 PKG_NAME:=zeromq
 PKG_VERSION:=4.3.4
-PKG_RELEASE:=3
+PKG_RELEASE:=4
 
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
 PKG_SOURCE_URL:=https://github.com/zeromq/libzmq/releases/download/v$(PKG_VERSION)
diff --git a/libs/zmq/patches/0001-fix-openpgm-linking-for-zeromq.patch b/libs/zmq/patches/0001-fix-openpgm-linking-for-zeromq.patch
deleted file mode 100644 (file)
index c699aa2..0000000
+++ /dev/null
@@ -1,40 +0,0 @@
-From 68546793d3ead9fef78f4b6670b4bee92ae99bc8 Mon Sep 17 00:00:00 2001
-From: Ye Holmes <yeholmes@outlook.com>
-Date: Wed, 17 Feb 2021 19:26:52 +0800
-Subject: [PATCH] fix-openpgm-linking-for-zeromq
-
----
- CMakeLists.txt | 8 +++++++-
- 1 file changed, 7 insertions(+), 1 deletion(-)
-
---- a/CMakeLists.txt
-+++ b/CMakeLists.txt
-@@ -793,7 +793,7 @@ else()
-     # message(FATAL_ERROR "WITH_OPENPGM not implemented")
-     if(NOT OPENPGM_PKGCONFIG_NAME)
--      set(OPENPGM_PKGCONFIG_NAME "openpgm-5.2")
-+      set(OPENPGM_PKGCONFIG_NAME "openpgm-5.3")
-     endif()
-     set(OPENPGM_PKGCONFIG_NAME
-@@ -804,6 +804,8 @@ else()
-     if(OPENPGM_FOUND)
-       message(STATUS ${OPENPGM_PKGCONFIG_NAME}" found")
-+      find_library(OPENPGM_LIBRARIES NAMES libpgm pgm)
-+      set(pkg_config_libs_private "${pkg_config_libs_private} -lpgm")
-       set(pkg_config_names_private "${pkg_config_names_private} ${OPENPGM_PKGCONFIG_NAME}")
-     else()
-       message(
-@@ -1447,6 +1449,10 @@ if(BUILD_SHARED)
-     endif()
-   endif()
-+  if(OPENPGM_FOUND)
-+   target_link_libraries(libzmq ${OPENPGM_LIBRARIES})
-+  endif()
-+
-   if(HAVE_WS2_32)
-     target_link_libraries(libzmq ws2_32)
-   elseif(HAVE_WS2)
diff --git a/libs/zmq/patches/010-fix-openpgm-linking-for-zeromq.patch b/libs/zmq/patches/010-fix-openpgm-linking-for-zeromq.patch
new file mode 100644 (file)
index 0000000..c699aa2
--- /dev/null
@@ -0,0 +1,40 @@
+From 68546793d3ead9fef78f4b6670b4bee92ae99bc8 Mon Sep 17 00:00:00 2001
+From: Ye Holmes <yeholmes@outlook.com>
+Date: Wed, 17 Feb 2021 19:26:52 +0800
+Subject: [PATCH] fix-openpgm-linking-for-zeromq
+
+---
+ CMakeLists.txt | 8 +++++++-
+ 1 file changed, 7 insertions(+), 1 deletion(-)
+
+--- a/CMakeLists.txt
++++ b/CMakeLists.txt
+@@ -793,7 +793,7 @@ else()
+     # message(FATAL_ERROR "WITH_OPENPGM not implemented")
+     if(NOT OPENPGM_PKGCONFIG_NAME)
+-      set(OPENPGM_PKGCONFIG_NAME "openpgm-5.2")
++      set(OPENPGM_PKGCONFIG_NAME "openpgm-5.3")
+     endif()
+     set(OPENPGM_PKGCONFIG_NAME
+@@ -804,6 +804,8 @@ else()
+     if(OPENPGM_FOUND)
+       message(STATUS ${OPENPGM_PKGCONFIG_NAME}" found")
++      find_library(OPENPGM_LIBRARIES NAMES libpgm pgm)
++      set(pkg_config_libs_private "${pkg_config_libs_private} -lpgm")
+       set(pkg_config_names_private "${pkg_config_names_private} ${OPENPGM_PKGCONFIG_NAME}")
+     else()
+       message(
+@@ -1447,6 +1449,10 @@ if(BUILD_SHARED)
+     endif()
+   endif()
++  if(OPENPGM_FOUND)
++   target_link_libraries(libzmq ${OPENPGM_LIBRARIES})
++  endif()
++
+   if(HAVE_WS2_32)
+     target_link_libraries(libzmq ws2_32)
+   elseif(HAVE_WS2)
diff --git a/libs/zmq/patches/030-gcc13-compatibility.patch b/libs/zmq/patches/030-gcc13-compatibility.patch
new file mode 100644 (file)
index 0000000..b8c7489
--- /dev/null
@@ -0,0 +1,58 @@
+Patch-Source: https://github.com/zeromq/libzmq/commit/438d5d88392baffa6c2c5e0737d9de19d6686f0d
+--
+From 438d5d88392baffa6c2c5e0737d9de19d6686f0d Mon Sep 17 00:00:00 2001
+From: Sergei Trofimovich <slyich@gmail.com>
+Date: Tue, 20 Dec 2022 21:45:16 +0000
+Subject: [PATCH] src/secure_allocator.hpp: define missing 'rebind' type
+
+`gcc-13` added an assert to standard headers to make sure custom
+allocators have intended implementation of rebind type instead
+of inherited rebind. gcc change:
+    https://gcc.gnu.org/git/?p=gcc.git;a=commitdiff;h=64c986b49558a7
+
+Without the fix build fails on this week's `gcc-13` as:
+
+    [ 92%] Building CXX object tests/CMakeFiles/test_security_curve.dir/test_security_curve.cpp.o
+    In file included from /<<NIX>>/gcc-13.0.0/include/c++/13.0.0/ext/alloc_traits.h:34,
+                     from /<<NIX>>/gcc-13.0.0/include/c++/13.0.0/bits/stl_uninitialized.h:64,
+                     from /<<NIX>>/gcc-13.0.0/include/c++/13.0.0/memory:69,
+                     from tests/../src/secure_allocator.hpp:42,
+                     from tests/../src/curve_client_tools.hpp:49,
+                     from tests/test_security_curve.cpp:53:
+    /<<NIX>>/gcc-13.0.0/include/c++/13.0.0/bits/alloc_traits.h: In instantiation of 'struct std::__allocator_traits_base::__rebind<zmq::secure_allocator_t<unsigned char>, unsigned char, void>':
+    /<<NIX>>/gcc-13.0.0/include/c++/13.0.0/bits/alloc_traits.h:94:11:   required by substitution of 'template<class _Alloc, class _Up> using std::__alloc_rebind = typename std::__allocator_traits_base::__rebind<_Alloc, _Up>::type [with _Alloc = zmq::secure_allocator_t<unsigned char>; _Up = unsigned char]'
+    /<<NIX>>/gcc-13.0.0/include/c++/13.0.0/bits/alloc_traits.h:228:8:   required by substitution of 'template<class _Alloc> template<class _Tp> using std::allocator_traits< <template-parameter-1-1> >::rebind_alloc = std::__alloc_rebind<_Alloc, _Tp> [with _Tp = unsigned char; _Alloc = zmq::secure_allocator_t<unsigned char>]'
+    /<<NIX>>/gcc-13.0.0/include/c++/13.0.0/ext/alloc_traits.h:126:65:   required from 'struct __gnu_cxx::__alloc_traits<zmq::secure_allocator_t<unsigned char>, unsigned char>::rebind<unsigned char>'
+    /<<NIX>>/gcc-13.0.0/include/c++/13.0.0/bits/stl_vector.h:88:21:   required from 'struct std::_Vector_base<unsigned char, zmq::secure_allocator_t<unsigned char> >'
+    /<<NIX>>/gcc-13.0.0/include/c++/13.0.0/bits/stl_vector.h:423:11:   required from 'class std::vector<unsigned char, zmq::secure_allocator_t<unsigned char> >'
+    tests/../src/curve_client_tools.hpp:64:76:   required from here
+    /<<NIX>>/gcc-13.0.0/include/c++/13.0.0/bits/alloc_traits.h:70:31: error: static assertion failed: allocator_traits<A>::rebind_alloc<A::value_type> must be A
+       70 |                         _Tp>::value,
+          |                               ^~~~~
+
+The change adds trivial `rebind` definition with expected return type
+and satisfies conversion requirements.
+---
+ src/secure_allocator.hpp | 11 +++++++++++
+ 1 file changed, 11 insertions(+)
+
+--- a/src/secure_allocator.hpp
++++ b/src/secure_allocator.hpp
+@@ -95,6 +95,17 @@ bool operator!= (const secure_allocator_
+ #else
+ template <typename T> struct secure_allocator_t : std::allocator<T>
+ {
++    secure_allocator_t () ZMQ_DEFAULT;
++
++    template <class U>
++    secure_allocator_t (const secure_allocator_t<U> &) ZMQ_NOEXCEPT
++    {
++    }
++
++    template <class U> struct rebind
++    {
++        typedef secure_allocator_t<U> other;
++    };
+ };
+ #endif
+ }