knot-resolver: update to version 5.4.3
authorJosef Schlehofer <pepe.schlehofer@gmail.com>
Tue, 7 Dec 2021 09:48:23 +0000 (10:48 +0100)
committerJosef Schlehofer <pepe.schlehofer@gmail.com>
Tue, 7 Dec 2021 21:54:34 +0000 (22:54 +0100)
Release notes:
https://www.knot-resolver.cz/2021-12-01-knot-resolver-5.4.3.html

Signed-off-by: Josef Schlehofer <pepe.schlehofer@gmail.com>
(cherry picked from commit 10ab2306702c5292f98a43cf5a1dfc0b7ab99c27)

net/knot-resolver/Makefile
net/knot-resolver/patches/030-fix-policy-hack.patch

index f9edcb21c382684d2ba2514f43ef7390441d1e87..652566f625391cd41c93a69374fd825a4752b8d8 100644 (file)
@@ -10,12 +10,12 @@ PKG_RELRO_FULL:=0
 include $(TOPDIR)/rules.mk
 
 PKG_NAME:=knot-resolver
-PKG_VERSION:=5.4.2
+PKG_VERSION:=5.4.3
 PKG_RELEASE:=1
 
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.xz
 PKG_SOURCE_URL:=https://secure.nic.cz/files/knot-resolver
-PKG_HASH:=ea6a219571a752056669bae3f2c0c3ed0bec58af5ab832d505a3ec9c4063a58b
+PKG_HASH:=488729eb93190336b6bca10de0d78ecb7919f77fcab105debc0a644aa7d0a506
 
 PKG_MAINTAINER:=Jan Pavlinec <jan.pavlinec@nic.cz>
 PKG_LICENSE:=GPL-3.0-later
index f7d46bafd3f2b893d530298ce5d667437e55a1d6..991dddd96977c84c3f1da4b9aa54f80026052cc2 100644 (file)
@@ -2,7 +2,7 @@ This patch fixes the problem with forwarding in knot-resolver v4.3.0.
 It reintroduces a fix which enables  policy related hack (knot/knot-resolver#205 (comment 94566) )
 --- a/modules/policy/policy.lua
 +++ b/modules/policy/policy.lua
-@@ -1000,7 +1000,7 @@ policy.layer = {
+@@ -1047,7 +1047,7 @@ policy.layer = {
                if bit.band(state, bit.bor(kres.FAIL, kres.DONE)) ~= 0 then return state end
                local qry = req:initial() -- same as :current() but more descriptive
                return policy.evaluate(policy.rules, req, qry, state)