libmikmod: fix autoreconf
authorJo-Philipp Wich <jow@openwrt.org>
Sun, 12 Dec 2010 19:37:38 +0000 (19:37 +0000)
committerJo-Philipp Wich <jow@openwrt.org>
Sun, 12 Dec 2010 19:37:38 +0000 (19:37 +0000)
SVN-Revision: 24522

libs/libmikmod/patches/002-missing-macros.patch [new file with mode: 0644]
libs/libmikmod/patches/003-automake-compat.patch [new file with mode: 0644]

diff --git a/libs/libmikmod/patches/002-missing-macros.patch b/libs/libmikmod/patches/002-missing-macros.patch
new file mode 100644 (file)
index 0000000..5bc07a6
--- /dev/null
@@ -0,0 +1,198 @@
+--- /dev/null
++++ b/acinclude.m4
+@@ -0,0 +1,195 @@
++# Configure paths for ESD
++# Manish Singh    98-9-30
++# stolen back from Frank Belew
++# stolen from Manish Singh
++# Shamelessly stolen from Owen Taylor
++
++dnl AM_PATH_ESD([MINIMUM-VERSION, [ACTION-IF-FOUND [, ACTION-IF-NOT-FOUND]]])
++dnl Test for ESD, and define ESD_CFLAGS and ESD_LIBS
++dnl
++AC_DEFUN(AM_PATH_ESD,
++[dnl 
++dnl Get the cflags and libraries from the esd-config script
++dnl
++AC_ARG_WITH(esd-prefix,[  --with-esd-prefix=PFX   Prefix where ESD is installed (optional)],
++            esd_prefix="$withval", esd_prefix="")
++AC_ARG_WITH(esd-exec-prefix,[  --with-esd-exec-prefix=PFX Exec prefix where ESD is installed (optional)],
++            esd_exec_prefix="$withval", esd_exec_prefix="")
++AC_ARG_ENABLE(esdtest, [  --disable-esdtest       Do not try to compile and run a test ESD program],
++                  , enable_esdtest=yes)
++
++  if test x$esd_exec_prefix != x ; then
++     esd_args="$esd_args --exec-prefix=$esd_exec_prefix"
++     if test x${ESD_CONFIG+set} != xset ; then
++        ESD_CONFIG=$esd_exec_prefix/bin/esd-config
++     fi
++  fi
++  if test x$esd_prefix != x ; then
++     esd_args="$esd_args --prefix=$esd_prefix"
++     if test x${ESD_CONFIG+set} != xset ; then
++        ESD_CONFIG=$esd_prefix/bin/esd-config
++     fi
++  fi
++
++  AC_PATH_PROG(ESD_CONFIG, esd-config, no)
++  min_esd_version=ifelse([$1], ,0.2.7,$1)
++  AC_MSG_CHECKING(for ESD - version >= $min_esd_version)
++  no_esd=""
++  if test "$ESD_CONFIG" = "no" ; then
++    no_esd=yes
++  else
++    AC_LANG_SAVE
++    AC_LANG_C
++    ESD_CFLAGS=`$ESD_CONFIG $esdconf_args --cflags`
++    ESD_LIBS=`$ESD_CONFIG $esdconf_args --libs`
++
++    esd_major_version=`$ESD_CONFIG $esd_args --version | \
++           sed 's/\([[0-9]]*\).\([[0-9]]*\).\([[0-9]]*\)/\1/'`
++    esd_minor_version=`$ESD_CONFIG $esd_args --version | \
++           sed 's/\([[0-9]]*\).\([[0-9]]*\).\([[0-9]]*\)/\2/'`
++    esd_micro_version=`$ESD_CONFIG $esd_config_args --version | \
++           sed 's/\([[0-9]]*\).\([[0-9]]*\).\([[0-9]]*\)/\3/'`
++    if test "x$enable_esdtest" = "xyes" ; then
++      ac_save_CFLAGS="$CFLAGS"
++      ac_save_LIBS="$LIBS"
++      CFLAGS="$CFLAGS $ESD_CFLAGS"
++      LIBS="$LIBS $ESD_LIBS"
++dnl
++dnl Now check if the installed ESD is sufficiently new. (Also sanity
++dnl checks the results of esd-config to some extent
++dnl
++      rm -f conf.esdtest
++      AC_TRY_RUN([
++#include <stdio.h>
++#include <stdlib.h>
++#include <string.h>
++#include <esd.h>
++
++char*
++my_strdup (char *str)
++{
++  char *new_str;
++  
++  if (str)
++    {
++      new_str = malloc ((strlen (str) + 1) * sizeof(char));
++      strcpy (new_str, str);
++    }
++  else
++    new_str = NULL;
++  
++  return new_str;
++}
++
++int main ()
++{
++  int major, minor, micro;
++  char *tmp_version;
++
++  system ("touch conf.esdtest");
++
++  /* HP/UX 9 (%@#!) writes to sscanf strings */
++  tmp_version = my_strdup("$min_esd_version");
++  if (sscanf(tmp_version, "%d.%d.%d", &major, &minor, &micro) != 3) {
++     printf("%s, bad version string\n", "$min_esd_version");
++     exit(1);
++   }
++
++   if (($esd_major_version > major) ||
++      (($esd_major_version == major) && ($esd_minor_version > minor)) ||
++      (($esd_major_version == major) && ($esd_minor_version == minor) && ($esd_micro_version >= micro)))
++    {
++      return 0;
++    }
++  else
++    {
++      printf("\n*** 'esd-config --version' returned %d.%d.%d, but the minimum version\n", $esd_major_version, $esd_minor_version, $esd_micro_version);
++      printf("*** of ESD required is %d.%d.%d. If esd-config is correct, then it is\n", major, minor, micro);
++      printf("*** best to upgrade to the required version.\n");
++      printf("*** If esd-config was wrong, set the environment variable ESD_CONFIG\n");
++      printf("*** to point to the correct copy of esd-config, and remove the file\n");
++      printf("*** config.cache before re-running configure\n");
++      return 1;
++    }
++}
++
++],, no_esd=yes,[echo $ac_n "cross compiling; assumed OK... $ac_c"])
++       CFLAGS="$ac_save_CFLAGS"
++       LIBS="$ac_save_LIBS"
++       AC_LANG_RESTORE
++     fi
++  fi
++  if test "x$no_esd" = x ; then
++     AC_MSG_RESULT(yes)
++     ifelse([$2], , :, [$2])     
++  else
++     AC_MSG_RESULT(no)
++     if test "$ESD_CONFIG" = "no" ; then
++       echo "*** The esd-config script installed by ESD could not be found"
++       echo "*** If ESD was installed in PREFIX, make sure PREFIX/bin is in"
++       echo "*** your path, or set the ESD_CONFIG environment variable to the"
++       echo "*** full path to esd-config."
++     else
++       if test -f conf.esdtest ; then
++        :
++       else
++          echo "*** Could not run ESD test program, checking why..."
++          CFLAGS="$CFLAGS $ESD_CFLAGS"
++          LIBS="$LIBS $ESD_LIBS"
++          AC_LANG_SAVE
++          AC_LANG_C
++          AC_TRY_LINK([
++#include <stdio.h>
++#include <esd.h>
++],      [ return 0; ],
++        [ echo "*** The test program compiled, but did not run. This usually means"
++          echo "*** that the run-time linker is not finding ESD or finding the wrong"
++          echo "*** version of ESD. If it is not finding ESD, you'll need to set your"
++          echo "*** LD_LIBRARY_PATH environment variable, or edit /etc/ld.so.conf to point"
++          echo "*** to the installed location  Also, make sure you have run ldconfig if that"
++          echo "*** is required on your system"
++        echo "***"
++          echo "*** If you have an old version installed, it is best to remove it, although"
++          echo "*** you may also be able to get things to work by modifying LD_LIBRARY_PATH"],
++        [ echo "*** The test program failed to compile or link. See the file config.log for the"
++          echo "*** exact error that occured. This usually means ESD was incorrectly installed"
++          echo "*** or that you have moved ESD since it was installed. In the latter case, you"
++          echo "*** may want to edit the esd-config script: $ESD_CONFIG" ])
++          CFLAGS="$ac_save_CFLAGS"
++          LIBS="$ac_save_LIBS"
++          AC_LANG_RESTORE
++       fi
++     fi
++     ESD_CFLAGS=""
++     ESD_LIBS=""
++     ifelse([$3], , :, [$3])
++  fi
++  AC_SUBST(ESD_CFLAGS)
++  AC_SUBST(ESD_LIBS)
++  rm -f conf.esdtest
++])
++
++dnl AM_ESD_SUPPORTS_MULTIPLE_RECORD([ACTION-IF-SUPPORTS [, ACTION-IF-NOT-SUPPORTS]])
++dnl Test, whether esd supports multiple recording clients (version >=0.2.21)
++dnl
++AC_DEFUN(AM_ESD_SUPPORTS_MULTIPLE_RECORD,
++[dnl
++  AC_MSG_NOTICE([whether installed esd version supports multiple recording clients])
++  ac_save_ESD_CFLAGS="$ESD_CFLAGS"
++  ac_save_ESD_LIBS="$ESD_LIBS"
++  AM_PATH_ESD(0.2.21,
++    ifelse([$1], , [
++      AM_CONDITIONAL(ESD_SUPPORTS_MULTIPLE_RECORD, true)
++      AC_DEFINE(ESD_SUPPORTS_MULTIPLE_RECORD, 1,
++      [Define if you have esound with support of multiple recording clients.])],
++    [$1]),
++    ifelse([$2], , [AM_CONDITIONAL(ESD_SUPPORTS_MULTIPLE_RECORD, false)], [$2])
++    if test "x$ac_save_ESD_CFLAGS" != x ; then
++       ESD_CFLAGS="$ac_save_ESD_CFLAGS"
++    fi
++    if test "x$ac_save_ESD_LIBS" != x ; then
++       ESD_LIBS="$ac_save_ESD_LIBS"
++    fi
++  )
++])
++
diff --git a/libs/libmikmod/patches/003-automake-compat.patch b/libs/libmikmod/patches/003-automake-compat.patch
new file mode 100644 (file)
index 0000000..bf94fca
--- /dev/null
@@ -0,0 +1,16 @@
+--- a/libmikmod-config.in
++++ b/libmikmod-config.in
+@@ -1,4 +1,4 @@
+-#! /bin/sh
++#! @SHELL@
+ prefix=@prefix@
+ exec_prefix=@exec_prefix@
+--- a/libmikmod/Makefile.in
++++ b/libmikmod/Makefile.in
+@@ -1,3 +1,5 @@
++SHELL = @SHELL@
++
+ exec_prefix=@exec_prefix@
+ prefix=@prefix@