mediatek: filogic: bpi-r4: set netdev-name for sfp ports
authorJonas Jelonek <jelonek.jonas@gmail.com>
Wed, 13 Nov 2024 22:25:09 +0000 (22:25 +0000)
committerPaul Spooren <mail@aparcar.org>
Fri, 20 Dec 2024 17:19:10 +0000 (18:19 +0100)
Sets openwrt,netdev-name for the gmac nodes in the dts of BPI-R4 which
correspond to the two sfp slots. By default they are automatically
named as eth1 and eth2 in bad order, however 'SFP1-WAN' and 'SFP2-LAN'
are printed on the PCB and the official metal case has labels 'SFP-WAN'
and 'SFP-LAN'. Thus, label the ports accordingly to match the
board/case labels.
The COMPAT_VERSION is increased to denote that configuration has to be
adjusted manually.

Signed-off-by: Jonas Jelonek <jelonek.jonas@gmail.com>
target/linux/mediatek/files-6.6/arch/arm64/boot/dts/mediatek/mt7988a-bananapi-bpi-r4-poe.dts
target/linux/mediatek/files-6.6/arch/arm64/boot/dts/mediatek/mt7988a-bananapi-bpi-r4.dts
target/linux/mediatek/files-6.6/arch/arm64/boot/dts/mediatek/mt7988a-bananapi-bpi-r4.dtsi
target/linux/mediatek/filogic/base-files/etc/board.d/02_network
target/linux/mediatek/filogic/base-files/etc/board.d/05_compat-version
target/linux/mediatek/image/filogic.mk

index efcf0ec35851ccd1914ebed713e58e2f5b03dd93..910f60d11b2255c84bebb9a43ac2d8c4ef2dad4e 100644 (file)
@@ -17,6 +17,7 @@
        phy-connection-type = "internal";
        phy = <&int_2p5g_phy>;
        status = "okay";
+       openwrt,netdev-name = "lan4";
 };
 
 &int_2p5g_phy {
index d2c223b4efaaa49e13002046f6559fc2e8d2fabc..0f8b6e3d03f5ad3b4386623145b1e40eaf1ce06e 100644 (file)
@@ -29,6 +29,7 @@
        managed = "in-band-status";
        phy-mode = "usxgmii";
        status = "okay";
+       openwrt,netdev-name = "sfp-lan";
 };
 
 &pca9545 {
index c4455fbc7471edb879b51ece42f88ca3cb74aec3..8dba5b4275fbcad2f2a88f0093c774cfe4f98ce2 100644 (file)
@@ -90,6 +90,7 @@
        managed = "in-band-status";
        phy-mode = "usxgmii";
        status = "okay";
+       openwrt,netdev-name = "sfp-wan";
 };
 
 &switch {
index 85422fe1f63ee539a83e206801385d241d9d3d9b..12dca517127268d643a02d0f5b96a821023f007c 100644 (file)
@@ -65,9 +65,11 @@ mediatek_setup_interfaces()
        edgecore,eap111)
                ucidef_set_interfaces_lan_wan eth0 eth1
                ;;
-       bananapi,bpi-r4|\
+       bananapi,bpi-r4)
+               ucidef_set_interfaces_lan_wan "lan1 lan2 lan3 sfp-lan" "wan sfp-wan"
+               ;;
        bananapi,bpi-r4-poe)
-               ucidef_set_interfaces_lan_wan "lan1 lan2 lan3 eth1" "wan eth2"
+               ucidef_set_interfaces_lan_wan "lan1 lan2 lan3 lan4" "wan sfp-wan"
                ;;
        comfast,cf-e393ax)
                ucidef_set_interfaces_lan_wan "lan1" eth1
index 48c040613c952de2db73dcb5cda161338482d26e..5ffc4e33743ba9ba0aa5d767763c07fb173450ee 100644 (file)
@@ -11,6 +11,10 @@ case "$(board_name)" in
        routerich,ax3000)
                ucidef_set_compat_version "1.1"
                ;;
+       bananapi,bpi-r4|\
+       bananapi,bpi-r4-poe)
+               ucidef_set_compat_version "1.1"
+               ;;
 esac
 
 board_config_flush
index 825e4abbad54f338f69ab84f56e523af0de9cf3d..abc6fc1e09103168d5a42af7dde9b95841be8fb9 100644 (file)
@@ -433,6 +433,8 @@ define Device/bananapi_bpi-r4-common
   DEVICE_DTC_FLAGS := --pad 4096
   DEVICE_PACKAGES := kmod-hwmon-pwmfan kmod-i2c-mux-pca954x kmod-eeprom-at24 kmod-mt7996-firmware kmod-mt7996-233-firmware \
                     kmod-rtc-pcf8563 kmod-sfp kmod-usb3 e2fsprogs f2fsck mkf2fs mt7988-wo-firmware
+  DEVICE_COMPAT_VERSION := 1.1
+  DEVICE_COMPAT_MESSAGE := The non-switch ports were renamed to match the board/case labels
   IMAGES := sysupgrade.itb
   KERNEL_LOADADDR := 0x46000000
   KERNEL_INITRAMFS_SUFFIX := -recovery.itb