openvswitch: change order of the installs
authorAlexandru Ardelean <aa@ocedo.com>
Thu, 18 Sep 2014 08:24:43 +0000 (11:24 +0300)
committerAlexandru Ardelean <aa@ocedo.com>
Thu, 18 Sep 2014 14:21:58 +0000 (17:21 +0300)
Signed-off-by: Alexandru Ardelean <ardeleanalex@gmail.com>
net/openvswitch/Makefile

index 6a199f22f698a3748e2fa92812467dc2851c9661..05a46510eb878a47ab23dc4ae31893e72478b7dd 100644 (file)
@@ -123,16 +123,6 @@ define Build/Compile
                KCC="$(KERNEL_CC)"
 endef
 
-define Package/openvswitch-ipsec/install
-       $(INSTALL_DIR) $(1)/usr/sbin/
-       $(INSTALL_BIN) $(PKG_BUILD_DIR)/debian/ovs-monitor-ipsec $(1)/usr/sbin/
-endef
-
-define Package/openvswitch-benchmark/install
-       $(INSTALL_DIR) $(1)/usr/bin/
-       $(INSTALL_BIN) $(PKG_BUILD_DIR)/utilities/.libs/ovs-benchmark $(1)/usr/bin/
-endef
-
 define Package/openvswitch/install
        $(INSTALL_DIR) $(1)/etc/openvswitch
 
@@ -162,6 +152,16 @@ define Package/openvswitch/install
        $(INSTALL_CONF) $(PKG_BUILD_DIR)/vswitchd/vswitch.ovsschema $(1)/usr/share/openvswitch/
 endef
 
+define Package/openvswitch-ipsec/install
+       $(INSTALL_DIR) $(1)/usr/sbin/
+       $(INSTALL_BIN) $(PKG_BUILD_DIR)/debian/ovs-monitor-ipsec $(1)/usr/sbin/
+endef
+
+define Package/openvswitch-benchmark/install
+       $(INSTALL_DIR) $(1)/usr/bin/
+       $(INSTALL_BIN) $(PKG_BUILD_DIR)/utilities/.libs/ovs-benchmark $(1)/usr/bin/
+endef
+
 define Package/openvswitch/postinst
 #!/bin/sh
 [ -n "$${IPKG_INSTROOT}" ] || /etc/init.d/openvswitch enable || true