projects
/
feed
/
packages.git
/ commitdiff
commit
grep
author
committer
pickaxe
?
search:
re
summary
|
shortlog
|
log
|
commit
| commitdiff |
tree
raw
|
patch
| inline |
side by side
(parent:
b4a3ac3
)
rsync: Add IPv6 functionality
author
Simon Tretter
<simon@mediaarchitectu.re>
Fri, 6 Jul 2018 08:50:10 +0000
(16:50 +0800)
committer
Yousong Zhou
<yszhou4tech@gmail.com>
Fri, 6 Jul 2018 08:57:41 +0000
(16:57 +0800)
Signed-off-by: Simon Tretter <simon@mediaarchitectu.re>
net/rsync/Makefile
patch
|
blob
|
history
diff --git
a/net/rsync/Makefile
b/net/rsync/Makefile
index f6701f86c59de8835c8d86648526b2355904a126..02ce086359b09a16a6b23cd94763c60ae7e3de4b 100644
(file)
--- a/
net/rsync/Makefile
+++ b/
net/rsync/Makefile
@@
-9,7
+9,7
@@
include $(TOPDIR)/rules.mk
PKG_NAME:=rsync
PKG_VERSION:=3.1.3
-PKG_RELEASE:=
1
+PKG_RELEASE:=
2
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
PKG_SOURCE_URL:=https://download.samba.org/pub/rsync/src
@@
-60,6
+60,12
@@
else
CONFIGURE_ARGS+= --with-included-zlib=yes
endif
+ifeq ($(CONFIG_IPV6),y)
+ TARGET_CFLAGS+= -DINET6
+else
+ CONFIGURE_ARGS+= --disable-ipv6
+endif
+
define Package/rsyncd
SECTION:=net
CATEGORY:=Network