Fix gcom downloading, normalize archive, use download target from pkg_template, defin...
authorFlorian Fainelli <florian@openwrt.org>
Tue, 11 Jul 2006 13:53:20 +0000 (13:53 +0000)
committerFlorian Fainelli <florian@openwrt.org>
Tue, 11 Jul 2006 13:53:20 +0000 (13:53 +0000)
SVN-Revision: 4128

openwrt/package/gcom/Makefile
openwrt/package/gcom/patches/001-Makefile.patch

index cc739a4df669dedecfbd9492d27c8aa69caffdb2..688b8cd8099959c2d19dea2235fa1bf1e9a6c0bf 100644 (file)
@@ -5,10 +5,10 @@ include $(TOPDIR)/rules.mk
 PKG_NAME:=gcom
 PKG_VERSION:=0.3
 PKG_RELEASE:=1
-PKG_MD5SUM:=cd32663025ed94a0ee623a689989f3c3
+PKG_MD5SUM:=f9bc8fde70278f1e990c705ccf2ae700
 
-PKG_SOURCE_URL:=http://www.pharscape.org/3G/gcom
-PKG_SOURCE:=$(PKG_NAME)$(PKG_VERSION).tgz
+PKG_SOURCE_URL:=http://downloads.openwrt.org/sources/
+PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tgz
 PKG_CAT:=zcat
 
 PKG_BUILD_DIR:=$(BUILD_DIR)/$(PKG_NAME)-$(PKG_VERSION)
@@ -18,14 +18,6 @@ include $(TOPDIR)/package/rules.mk
 
 $(eval $(call PKG_template,GCOM,$(PKG_NAME),$(PKG_VERSION)-$(PKG_RELEASE),$(ARCH)))
 
-$(PKG_BUILD_DIR)/.prepared:
-       rm -rf $(PKG_BUILD_DIR)
-       mkdir -p $(PKG_BUILD_DIR)
-       # the .tgz is different - no subdirectory, so do this manually
-       zcat $(DL_DIR)/$(PKG_SOURCE) | tar -C $(PKG_BUILD_DIR) $(TAR_OPTIONS) -
-       if [ -d ./patches ]; then $(PATCH) $(PKG_BUILD_DIR) ./patches ; fi
-       touch $@
-
 $(PKG_BUILD_DIR)/.configured:
        touch $@
 
index 28ea2ecf27ff4d056561a624168a748b9af8c384..bf0bb52eeca0d6dc0cb50dc42b5a970e2cf7533e 100644 (file)
@@ -1,5 +1,5 @@
---- gcom-0.3.x/Makefile        2006-01-04 17:05:28.000000000 +0200
-+++ gcom-0.3/Makefile  2006-02-26 13:02:07.000000000 +0200
+--- gcom-0.3/Makefile  2006-01-04 16:05:28.000000000 +0100
++++ gcom-0.3.new/Makefile      2006-07-11 15:09:50.000000000 +0200
 @@ -20,8 +20,6 @@
  #
  #     $Id$