python3: do a simple ls on pip & setuptools if not selected for build
authorAlexandru Ardelean <ardeleanalex@gmail.com>
Mon, 5 Jul 2021 08:28:38 +0000 (11:28 +0300)
committerJosef Schlehofer <pepe.schlehofer@gmail.com>
Tue, 6 Jul 2021 14:20:18 +0000 (16:20 +0200)
I seem to forget to check/select setuptools and pip (that come bundled with
Python).
This change will do a simple 'ls' on the 2 wheel files, so that the build
fails even if just building Python.

Signed-off-by: Alexandru Ardelean <ardeleanalex@gmail.com>
lang/python/python3/Makefile

index dc6423c96ef0168b621d3ba0daa2fc36ffb3da59..17356c71e27776df76fee965fa3678e6961631e2 100644 (file)
@@ -190,6 +190,10 @@ define Build/Compile/python3-setuptools
                $(PKG_BUILD_DIR)/Lib/ensurepip/_bundled/setuptools-$(PYTHON3_SETUPTOOLS_VERSION)-py3-none-any.whl
        $(call PatchDir,$(PKG_BUILD_DIR)/install-setuptools/usr/lib/python$(PYTHON3_VERSION)/site-packages,./patches-setuptools,)
 endef
+else
+define Build/Compile/python3-setuptools
+       ls $(PKG_BUILD_DIR)/Lib/ensurepip/_bundled/setuptools-$(PYTHON3_SETUPTOOLS_VERSION)-py3-none-any.whl
+endef
 endif # CONFIG_PACKAGE_python3-setuptools
 
 ifdef CONFIG_PACKAGE_python3-pip
@@ -204,6 +208,10 @@ define Build/Compile/python3-pip
                $(PKG_BUILD_DIR)/Lib/ensurepip/_bundled/pip-$(PYTHON3_PIP_VERSION)-py3-none-any.whl
        $(call PatchDir,$(PKG_BUILD_DIR)/install-pip/usr/lib/python$(PYTHON3_VERSION)/site-packages,./patches-pip,)
 endef
+else
+define Build/Compile/python3-pip
+       ls $(PKG_BUILD_DIR)/Lib/ensurepip/_bundled/pip-$(PYTHON3_PIP_VERSION)-py3-none-any.whl
+endef
 endif # CONFIG_PACKAGE_python3-pip
 
 define Build/Compile