python-orjson: update to version 3.10.12
authorTimothy M. Ace <openwrt@timothyace.com>
Wed, 11 Dec 2024 00:19:17 +0000 (19:19 -0500)
committerHannu Nyman <hannu.nyman@iki.fi>
Wed, 11 Dec 2024 16:55:52 +0000 (18:55 +0200)
Relevant changes since previous 3.10.0:
- FIXED: Serializing numpy.ndarray with non-native endianness raises orjson.JSONEncodeError.
- FIXED: Fix int serialization on 32-bit Python 3.8, 3.9, 3.10. This was introduced in 3.10.8.
- Improve performance of serializing.
- Drop support for arm7.
- int serialization no longer chains OverflowError to the the __cause__ attribute of orjson.JSONEncodeError when range exceeded.

Signed-off-by: Timothy M. Ace <openwrt@timothyace.com>
lang/python/python-orjson/Makefile

index 9352d65c62205623054ed9d46b06dba5c9707246..1b06c7f8ece2569aaa5c1bce9970f47bc24742d9 100644 (file)
@@ -1,11 +1,11 @@
 include $(TOPDIR)/rules.mk
 
 PKG_NAME:=python-orjson
-PKG_VERSION:=3.10.0
+PKG_VERSION:=3.10.12
 PKG_RELEASE:=1
 
 PYPI_NAME:=orjson
-PKG_HASH:=ba4d8cac5f2e2cff36bea6b6481cdb92b38c202bcec603d6f5ff91960595a1ed
+PKG_HASH:=0a78bbda3aea0f9f079057ee1ee8a1ecf790d4f1af88dd67493c6b8ee52506ff
 
 PKG_MAINTAINER:=Timothy Ace <openwrt@timothyace.com>
 PKG_LICENSE:=Apache-2.0 MIT