django-postoffice: update packaging format + add python3 variant
authorAlexandru Ardelean <ardeleanalex@gmail.com>
Tue, 25 Jun 2019 07:14:54 +0000 (10:14 +0300)
committerJosef Schlehofer <pepe.schlehofer@gmail.com>
Tue, 22 Oct 2019 23:51:12 +0000 (01:51 +0200)
Signed-off-by: Alexandru Ardelean <ardeleanalex@gmail.com>
(cherry-picked from commit 15272fcc65fdc28ab45f5642234c5139b90e2990)

lang/python/django-postoffice/Makefile
net/seafile-seahub/Makefile

index 1f1876db211ec82c1cf4e0b6e414675149e3b6d2..0a0a6f1671ee480ac07fdde89e1142bbe5567ca0 100644 (file)
@@ -9,40 +9,65 @@ include $(TOPDIR)/rules.mk
 
 PKG_NAME:=django-postoffice
 PKG_VERSION:=3.1.0
-PKG_RELEASE:=3
-PKG_LICENSE:=MIT
+PKG_RELEASE:=4
 
 PKG_SOURCE:=django-post_office-$(PKG_VERSION).tar.gz
 PKG_SOURCE_URL:=https://files.pythonhosted.org/packages/source/d/django-post_office
 PKG_HASH:=827937a944fe47cea393853069cd9315d080298c8ddb0faf787955d6aa51a030
-PKG_BUILD_DIR:=$(BUILD_DIR)/django-post_office-$(PKG_VERSION)
+
 PKG_MAINTAINER:=Alexandru Ardelean <ardeleanalex@gmail.com>
+PKG_LICENSE:=MIT
+PKG_LICENSE_FILES:=LICENSE.txt
+
+PKG_BUILD_DIR:=$(BUILD_DIR)/$(BUILD_VARIANT)-$(PKG_NAME)-$(PKG_VERSION)
 
 include $(INCLUDE_DIR)/package.mk
 include ../python-package.mk
+include ../python3-package.mk
 
-define Package/django-postoffice
+PKG_UNPACK:=$(HOST_TAR) -C $(PKG_BUILD_DIR) --strip-components=1 -xzf $(DL_DIR)/$(PKG_SOURCE)
+
+define Package/$(PKG_NAME)/Default
   SUBMENU:=Python
   SECTION:=lang
   CATEGORY:=Languages
-  TITLE:=A Django app to monitor and send mail asynchronously, complete with template support.
-  URL:=https://github.com/ui/django-postoffice
-  DEPENDS:=+python +python-django +django-jsonfield
+  TITLE:=A Django app to monitor and send mail asynchronously
+  URL:=https://github.com/ui/django-post_office
+endef
+
+define Package/python-$(PKG_NAME)
+$(call Package/$(PKG_NAME)/Default)
+  DEPENDS:= \
+       +PACKAGE_python-$(PKG_NAME):python \
+       +PACKAGE_python-$(PKG_NAME):python-django \
+       +PACKAGE_python-$(PKG_NAME):python-django-jsonfield
+  VARIANT:=python
 endef
 
-define Package/django-postoffice/description
-  A Django app to monitor and send mail asynchronously, complete with template support.
+define Package/python-$(PKG_NAME)/description
+  A Django app to monitor and send mail asynchronously, complete with template
+  support
 endef
 
-define Build/Compile
-       $(call Build/Compile/PyMod,,install --prefix=/usr --root=$(PKG_INSTALL_DIR))
+define Package/python3-$(PKG_NAME)
+$(call Package/$(PKG_NAME)/Default)
+  DEPENDS:= \
+       +PACKAGE_python3-$(PKG_NAME):python3 \
+       +PACKAGE_python3-$(PKG_NAME):python3-django \
+       +PACKAGE_python3-$(PKG_NAME):python3-django-jsonfield
+  VARIANT:=python3
 endef
 
-define Package/django-postoffice/install
-       $(INSTALL_DIR) $(1)$(PYTHON_PKG_DIR)
-       $(CP) \
-           $(PKG_INSTALL_DIR)$(PYTHON_PKG_DIR)/* \
-           $(1)$(PYTHON_PKG_DIR)
+define Package/python3-$(PKG_NAME)/description
+$(call define Package/python-$(PKG_NAME)/description)
+.
+(Variant for Python3)
 endef
 
-$(eval $(call BuildPackage,django-postoffice))
+$(eval $(call PyPackage,python-$(PKG_NAME)))
+$(eval $(call BuildPackage,python-$(PKG_NAME)))
+$(eval $(call BuildPackage,python-$(PKG_NAME)-src))
+
+$(eval $(call Py3Package,python3-$(PKG_NAME)))
+$(eval $(call BuildPackage,python3-$(PKG_NAME)))
+$(eval $(call BuildPackage,python3-$(PKG_NAME)-src))
index 78e78425e4b5dc62c5b5cb76f4adee53950d5cfb..7054330d4f63802d9df8ac7997d1924cc0a8457d 100644 (file)
@@ -25,7 +25,7 @@ include ../../lang/python/python-package.mk
 SEAFILE_PYTHON_DEPENDS:= \
        simplejson chardet dateutil mysql pytz qrcode requests requests-oauthlib \
        django django-constance django-appconf django-compressor django-formtools \
-       django-jsonfield django-picklefield 
+       django-jsonfield django-picklefield django-postoffice
 
 define Package/seafile-seahub
   SECTION:=net
@@ -33,7 +33,7 @@ define Package/seafile-seahub
   TITLE:=Seafile server - seahub component
   URL:=https://seafile.com/
   DEPENDS:=+python +pillow \
-       +django-postoffice +django-restframework \
+       +django-restframework \
        +django-simple-captcha +django-statici18n +django-webpack-loader \
        +flup +gunicorn +openpyxl \
        $(foreach dep,$(SEAFILE_PYTHON_DEPENDS),+python-$(dep))