nginx: upgrade to 1.2.3
authorFlorian Fainelli <florian@openwrt.org>
Tue, 4 Dec 2012 16:21:08 +0000 (16:21 +0000)
committerFlorian Fainelli <florian@openwrt.org>
Tue, 4 Dec 2012 16:21:08 +0000 (16:21 +0000)
Changelog: http://nginx.org/en/CHANGES-1.2

Signed-off-by: Mark Mentovai <mark@moxienet.com>
Signed-off-by: Florian Fainelli <florian@openwrt.org>
SVN-Revision: 34495

net/nginx/Makefile
net/nginx/patches/101-feature_test_fix.patch

index 722951a7647f748958b1c0bfa3b64ef490d5d23b..a09b59b2eb9353786f6c483a4632a7e553394e17 100644 (file)
@@ -8,12 +8,12 @@
 include $(TOPDIR)/rules.mk
 
 PKG_NAME:=nginx
-PKG_VERSION:=1.2.2
+PKG_VERSION:=1.2.3
 PKG_RELEASE:=1
 
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
 PKG_SOURCE_URL:=http://nginx.org/download/
-PKG_MD5SUM:=53105bbe3ac9319db54d9eb46119695b
+PKG_MD5SUM:=0a986e60826d9e3b453dbefc36bf8f6c
 
 PKG_BUILD_PARALLEL:=1
 PKG_INSTALL:=1
index cb84d84691e8c681845ba500dcff6a322ddb0d11..8e15fe96e81453e4c4d91cc730b11ea0a4f8e5d7 100644 (file)
@@ -11,7 +11,7 @@
      ngx_feature_libs=
 --- a/auto/cc/conf
 +++ b/auto/cc/conf
-@@ -149,7 +149,7 @@ if [ "$NGX_PLATFORM" != win32 ]; then
+@@ -155,7 +155,7 @@ if [ "$NGX_PLATFORM" != win32 ]; then
      else
          ngx_feature="C99 variadic macros"
          ngx_feature_name="NGX_HAVE_C99_VARIADIC_MACROS"
@@ -20,7 +20,7 @@
          ngx_feature_incs="#include <stdio.h>
  #define var(dummy, ...)  sprintf(__VA_ARGS__)"
          ngx_feature_path=
-@@ -163,7 +163,7 @@ if [ "$NGX_PLATFORM" != win32 ]; then
+@@ -169,7 +169,7 @@ if [ "$NGX_PLATFORM" != win32 ]; then
  
      ngx_feature="gcc variadic macros"
      ngx_feature_name="NGX_HAVE_GCC_VARIADIC_MACROS"